b1063a0136
From [1]: With version 2.0, the source code has been cleanly split into an application-oriented user library and a time-critical stack driver. The latter may be moved to a dedicated communication processor or into a kernel module to deliver enhanced performance while still keeping the API in user space. This new version break the API used in the v1.x but this is a complete rewrite of the Powerlink EPSG DS 301 implementation. The v1.x is deprecated anyway. The new build system has been split in several CMake projects which makes it difficult to package with the Buildroot CMake infra. So add a top level CMakeLists.txt to build each openpowerlink component without having to package each of them in a separate Buildroot packages. Also we need to fix the build system to support the top level CMake build. [1] http://sourceforge.net/projects/openpowerlink/ Signed-off-by: Romain Naour <romain.naour@gmail.com> [Thomas: - rename patches to not contain the [FIX] part in their title. - rewrap Config.in help text - rename "openPOWERLINK stack type" to "stack type" - rename ""openpowerlink demos" to "demos"] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
From c904fb6ce3c29e77d51d8bcbbbdd48b8d22c754b Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@openwide.fr>
|
|
Date: Mon, 4 May 2015 11:47:05 +0200
|
|
Subject: [PATCH] cmake: install oplk headers files
|
|
|
|
In order to be able to link a third party application
|
|
with openpowerlink libraries, we need to install the
|
|
oplk headers files related to openpowerlink stack.
|
|
|
|
Install all headers file from STACK_INCLUDE_DIR/oplk.
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
|
|
---
|
|
stack/CMakeLists.txt | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/stack/CMakeLists.txt b/stack/CMakeLists.txt
|
|
index 9ff13f4..f4614cd 100644
|
|
--- a/stack/CMakeLists.txt
|
|
+++ b/stack/CMakeLists.txt
|
|
@@ -103,3 +103,8 @@ ELSEIF((CMAKE_SYSTEM_NAME STREQUAL "Generic") AND (CMAKE_SYSTEM_PROCESSOR STREQU
|
|
ELSE()
|
|
MESSAGE(FATAL_ERROR "Unknown Platform and processor combination ${CMAKE_SYSTEM_NAME} and ${CMAKE_SYSTEM_PROCESSOR}!!")
|
|
ENDIF()
|
|
+
|
|
+################################################################################
|
|
+# Install oplk headers files
|
|
+################################################################################
|
|
+INSTALL(DIRECTORY ${STACK_INCLUDE_DIR}/oplk DESTINATION "include")
|
|
--
|
|
2.4.3
|
|
|