779501290f
Fix the following build failure with sigrok-cli raised since bump of
python3 to version 3.10.1 in commit
25b1fc2898
:
/home/giuliobenetti/autobuild/run/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/aarch64-none-linux-gnu/10.3.1/../../../../aarch64-none-linux-gnu/bin/ld: /home/giuliobenetti/autobuild/run/instance-3/output-1/host/bin/../aarch64-buildroot-linux-gnu/sysroot/usr/lib/libsigrokdecode.so: undefined reference to `PyTuple_SetItem'
Fixes:
- http://autobuild.buildroot.org/results/e2f33366803b18aff29086007610fa0a264f90d6
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
29 lines
1.4 KiB
Diff
29 lines
1.4 KiB
Diff
From c4c10b89396fe21a622b8c38dd5815a496b007bf Mon Sep 17 00:00:00 2001
|
|
From: Soeren Apel <soeren@apelpie.net>
|
|
Date: Mon, 20 Dec 2021 19:36:39 +0100
|
|
Subject: [PATCH] configure: Add python 3.10 support
|
|
|
|
[Retrieved from:
|
|
https://sigrok.org/gitweb/?p=libsigrokdecode.git;a=commitdiff;h=c4c10b89396fe21a622b8c38dd5815a496b007bf
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 2917cb3..b8841f8 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -100,7 +100,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
|
|
# first, since usually only that variant will add "-lpython3.8".
|
|
# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
|
|
SR_PKG_CHECK([python3], [SRD_PKGLIBS],
|
|
- [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
|
+ [python-3.10-embed], [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
|
AS_IF([test "x$sr_have_python3" = xno],
|
|
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])
|
|
|
|
--
|
|
2.24.0.rc2
|
|
|