b1662a165c
Switch from distutils to setuptools to avoid the following build failure raised since bump of python to version 3.12.1 in commit36e635d2d5
: Traceback (most recent call last): File "/home/fabrice/buildroot/output/build/libpwquality-1.4.5/python/setup.py", line 9, in <module> from distutils.core import setup, Extension ModuleNotFoundError: No module named 'distutils' Fixes:36e635d2d5
No autobuilder failures (yet) Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
79 lines
2.8 KiB
Diff
79 lines
2.8 KiB
Diff
From 7b5e0f0097faebdcc6a8b783237bbba7a983147a Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
|
Date: Fri, 31 Mar 2023 14:52:19 +0200
|
|
Subject: [PATCH] Use setuptools instead of distutils
|
|
|
|
distutils is removed from Python 3.12+:
|
|
https://peps.python.org/pep-0632/
|
|
|
|
Upstream: https://github.com/libpwquality/libpwquality/commit/7b5e0f0097faebdcc6a8b783237bbba7a983147a
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
libpwquality.spec.in | 11 ++---------
|
|
python/Makefile.am | 2 +-
|
|
python/setup.py.in | 6 +++---
|
|
3 files changed, 6 insertions(+), 13 deletions(-)
|
|
|
|
diff --git a/libpwquality.spec.in b/libpwquality.spec.in
|
|
index 70a6f53..0809126 100644
|
|
--- a/libpwquality.spec.in
|
|
+++ b/libpwquality.spec.in
|
|
@@ -33,9 +33,11 @@ BuildRequires: gettext
|
|
BuildRequires: pam-devel
|
|
%if %{with python2}
|
|
BuildRequires: python2-devel
|
|
+BuildRequires: python2-setuptools
|
|
%endif
|
|
%if %{with python3}
|
|
BuildRequires: python3-devel
|
|
+BuildRequires: python3-setuptools
|
|
%endif
|
|
|
|
URL: https://github.com/libpwquality/libpwquality/
|
|
@@ -103,15 +105,6 @@ cp -a . %{py3dir}
|
|
pushd %{py3dir}
|
|
%endif
|
|
%if %{with python3}
|
|
-# setuptools >= 60 changes the environment to use its bundled copy of distutils
|
|
-# by default, not the Python-bundled one. To run the Python's standard library
|
|
-# distutils, the environment variable must be set.
|
|
-# Although technically setuptools is not needed for this package, if it's
|
|
-# pulled by another package, it changes the environment and consequently,
|
|
-# the build fails. This was reported in:
|
|
-# https://github.com/pypa/setuptools/issues/3143
|
|
-export SETUPTOOLS_USE_DISTUTILS=stdlib
|
|
-
|
|
%configure \
|
|
--with-securedir=%{_moduledir} \
|
|
--with-pythonsitedir=%{python3_sitearch} \
|
|
diff --git a/python/Makefile.am b/python/Makefile.am
|
|
index 1d00c0c..6e51744 100644
|
|
--- a/python/Makefile.am
|
|
+++ b/python/Makefile.am
|
|
@@ -14,7 +14,7 @@ all-local:
|
|
CFLAGS="${CFLAGS} -fno-strict-aliasing" @PYTHONBINARY@ setup.py build --build-base py$(PYTHONREV)
|
|
|
|
install-exec-local:
|
|
- CFLAGS="${CFLAGS} -fno-strict-aliasing" @PYTHONBINARY@ setup.py build --build-base py$(PYTHONREV) install --prefix=${DESTDIR}${prefix}
|
|
+ CFLAGS="${CFLAGS} -fno-strict-aliasing" @PYTHONBINARY@ setup.py build --build-base py$(PYTHONREV) install --root ${DESTDIR} --prefix=${prefix}
|
|
|
|
clean-local:
|
|
rm -rf py$(PYTHONREV)
|
|
diff --git a/python/setup.py.in b/python/setup.py.in
|
|
index a741b91..f934c50 100755
|
|
--- a/python/setup.py.in
|
|
+++ b/python/setup.py.in
|
|
@@ -6,9 +6,9 @@
|
|
|
|
import os
|
|
|
|
-from distutils.core import setup, Extension
|
|
-from distutils.command.build_ext import build_ext as _build_ext
|
|
-from distutils.command.sdist import sdist as _sdist
|
|
+from setuptools import setup, Extension
|
|
+from setuptools.command.build_ext import build_ext as _build_ext
|
|
+from setuptools.command.sdist import sdist as _sdist
|
|
|
|
def genconstants(headerfile, outputfile):
|
|
hf = open(headerfile, 'r')
|