6dbb40955f
Needed for the upcoming Nexus version of kodi-inputstream-adaptive,
the bundled version of bento4 was removed upstream:
70625e7670
Backported upstream commit to fix cmake install as patch 0001.
Added feature- and bugfix-patches from kodi, they were sent upstream:
https://github.com/axiomatic-systems/Bento4/issues/648
Build-tested using this defconfig:
BR2_PACKAGE_BENTO4=y
andes-nds32 [ 1/45]: SKIPPED
arm-aarch64 [ 2/45]: OK
bootlin-aarch64-glibc [ 3/45]: OK
bootlin-arcle-hs38-uclibc [ 4/45]: OK
bootlin-armv5-uclibc [ 5/45]: OK
bootlin-armv7-glibc [ 6/45]: OK
bootlin-armv7m-uclibc [ 7/45]: OK
bootlin-armv7-musl [ 8/45]: OK
bootlin-m68k-5208-uclibc [ 9/45]: OK
bootlin-m68k-68040-uclibc [10/45]: OK
bootlin-microblazeel-uclibc [11/45]: OK
bootlin-mipsel32r6-glibc [12/45]: OK
bootlin-mipsel-uclibc [13/45]: OK
bootlin-nios2-glibc [14/45]: OK
bootlin-openrisc-uclibc [15/45]: OK
bootlin-powerpc64le-power8-glibc [16/45]: OK
bootlin-powerpc-e500mc-uclibc [17/45]: OK
bootlin-riscv32-glibc [18/45]: OK
bootlin-riscv64-glibc [19/45]: OK
bootlin-riscv64-musl [20/45]: OK
bootlin-sh4-uclibc [21/45]: OK
bootlin-sparc64-glibc [22/45]: OK
bootlin-sparc-uclibc [23/45]: OK
bootlin-x86-64-glibc [24/45]: OK
bootlin-x86-64-musl [25/45]: OK
bootlin-x86-64-uclibc [26/45]: OK
bootlin-xtensa-uclibc [27/45]: OK
br-arm-basic [28/45]: SKIPPED
br-arm-full-nothread [29/45]: OK
br-arm-full-static [30/45]: OK
br-i386-pentium4-full [31/45]: OK
br-i386-pentium-mmx-musl [32/45]: OK
br-mips64-n64-full [33/45]: OK
br-mips64r6-el-hf-glibc [34/45]: OK
br-powerpc-603e-basic-cpp [35/45]: OK
br-powerpc64-power7-glibc [36/45]: OK
linaro-aarch64-be [37/45]: OK
linaro-aarch64 [38/45]: OK
linaro-arm [39/45]: OK
sourcery-arm-armv4t [40/45]: OK
sourcery-arm [41/45]: OK
sourcery-arm-thumb2 [42/45]: OK
sourcery-mips64 [43/45]: OK
sourcery-mips [44/45]: OK
sourcery-nios2 [45/45]: OK
45 builds, 2 skipped, 0 build failed, 0 legal-info failed
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
131 lines
3.8 KiB
Diff
131 lines
3.8 KiB
Diff
From ba95f55c495c4c34c75a95de843acfa00f6afe24 Mon Sep 17 00:00:00 2001
|
|
From: Harry Mallon <harry.mallon@codex.online>
|
|
Date: Fri, 9 Jul 2021 15:50:26 +0100
|
|
Subject: [PATCH] Add support for cmake install
|
|
|
|
Downloaded from upstream commit
|
|
https://github.com/axiomatic-systems/Bento4/commit/ba95f55c495c4c34c75a95de843acfa00f6afe24
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
Build/cmake/Config.cmake.in | 4 ++
|
|
CMakeLists.txt | 73 ++++++++++++++++++++++++++++++++++---
|
|
2 files changed, 71 insertions(+), 6 deletions(-)
|
|
create mode 100644 Build/cmake/Config.cmake.in
|
|
|
|
diff --git a/Build/cmake/Config.cmake.in b/Build/cmake/Config.cmake.in
|
|
new file mode 100644
|
|
index 00000000..38bbde7b
|
|
--- /dev/null
|
|
+++ b/Build/cmake/Config.cmake.in
|
|
@@ -0,0 +1,4 @@
|
|
+@PACKAGE_INIT@
|
|
+
|
|
+include("${CMAKE_CURRENT_LIST_DIR}/@TARGETS_EXPORT_NAME@.cmake")
|
|
+check_required_components("@PROJECT_NAME@")
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 6de3bfe1..6ebf127f 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -7,7 +7,14 @@ else()
|
|
cmake_minimum_required(VERSION 3.10)
|
|
endif()
|
|
|
|
-project(bento4)
|
|
+function(get_bento4_version)
|
|
+ file(STRINGS "Source/C++/Core/Ap4Version.h" _temp REGEX "AP4_VERSION_STRING")
|
|
+ string(REGEX MATCH "\"([^\"]+)\"" _temp "${_temp}")
|
|
+ set(BENTO4_VERSION "${CMAKE_MATCH_1}" PARENT_SCOPE)
|
|
+endfunction()
|
|
+
|
|
+get_bento4_version()
|
|
+project(bento4 VERSION "${BENTO4_VERSION}")
|
|
|
|
# Variables
|
|
set(SOURCE_ROOT ${CMAKE_CURRENT_SOURCE_DIR}/Source/C++)
|
|
@@ -51,14 +58,22 @@ endif()
|
|
|
|
# Includes
|
|
set(AP4_INCLUDE_DIRS
|
|
- ${SOURCE_CORE}
|
|
- ${SOURCE_CODECS}
|
|
- ${SOURCE_CRYPTO}
|
|
- ${SOURCE_METADATA}
|
|
+ $<BUILD_INTERFACE:${SOURCE_CORE}>
|
|
+ $<BUILD_INTERFACE:${SOURCE_CODECS}>
|
|
+ $<BUILD_INTERFACE:${SOURCE_CRYPTO}>
|
|
+ $<BUILD_INTERFACE:${SOURCE_METADATA}>
|
|
+)
|
|
+file(GLOB AP4_HEADERS
|
|
+ ${SOURCE_CORE}/*.h
|
|
+ ${SOURCE_CODECS}/*.h
|
|
+ ${SOURCE_CRYPTO}/*.h
|
|
+ ${SOURCE_METADATA}/*.h
|
|
)
|
|
|
|
add_library(ap4 STATIC ${AP4_SOURCES})
|
|
-target_include_directories(ap4 PUBLIC ${AP4_INCLUDE_DIRS})
|
|
+target_include_directories(ap4 PUBLIC
|
|
+ ${AP4_INCLUDE_DIRS}
|
|
+)
|
|
|
|
# Use the statically linked C runtime library
|
|
if(MSVC)
|
|
@@ -72,6 +87,7 @@ if(BUILD_APPS)
|
|
file(GLOB BENTO4_APPS RELATIVE ${SOURCE_ROOT}/Apps ${SOURCE_ROOT}/Apps/*)
|
|
foreach(app ${BENTO4_APPS})
|
|
string(TOLOWER ${app} binary_name)
|
|
+ list(APPEND BENTO4_APPS_LOWERCASE ${binary_name})
|
|
add_executable(${binary_name} ${SOURCE_ROOT}/Apps/${app}/${app}.cpp)
|
|
target_link_libraries(${binary_name} ap4)
|
|
|
|
@@ -81,3 +97,48 @@ foreach(app ${BENTO4_APPS})
|
|
endif()
|
|
endforeach()
|
|
endif(BUILD_APPS)
|
|
+
|
|
+# Install
|
|
+include(GNUInstallDirs)
|
|
+set(config_install_dir "${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}")
|
|
+set(generated_dir "${CMAKE_CURRENT_BINARY_DIR}/generated")
|
|
+set(version_config "${generated_dir}/${PROJECT_NAME}ConfigVersion.cmake")
|
|
+set(project_config "${generated_dir}/${PROJECT_NAME}Config.cmake")
|
|
+set(TARGETS_EXPORT_NAME "${PROJECT_NAME}Targets")
|
|
+set(namespace "${PROJECT_NAME}::")
|
|
+
|
|
+include(CMakePackageConfigHelpers)
|
|
+write_basic_package_version_file(
|
|
+ "${version_config}" COMPATIBILITY SameMajorVersion
|
|
+)
|
|
+
|
|
+configure_package_config_file(
|
|
+ "Build/cmake/Config.cmake.in"
|
|
+ "${project_config}"
|
|
+ INSTALL_DESTINATION "${config_install_dir}"
|
|
+)
|
|
+
|
|
+install(
|
|
+ TARGETS ap4 ${BENTO4_APPS_LOWERCASE}
|
|
+ EXPORT "${TARGETS_EXPORT_NAME}"
|
|
+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
|
|
+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"
|
|
+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}"
|
|
+ INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
|
|
+)
|
|
+
|
|
+install(
|
|
+ FILES ${AP4_HEADERS}
|
|
+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/bento4"
|
|
+)
|
|
+
|
|
+install(
|
|
+ FILES "${project_config}" "${version_config}"
|
|
+ DESTINATION "${config_install_dir}"
|
|
+)
|
|
+
|
|
+install(
|
|
+ EXPORT "${TARGETS_EXPORT_NAME}"
|
|
+ NAMESPACE "${namespace}"
|
|
+ DESTINATION "${config_install_dir}"
|
|
+)
|