b7fcfb71d7
Disable execinfo to avoid the following build failure raised since the
addition of libexecinfo package in commit
eea8ba446c
:
/home/giuliobenetti/autobuild/run/instance-0/output-1/host/lib/gcc/arc-buildroot-linux-uclibc/10.2.0/../../../../arc-buildroot-linux-uclibc/bin/ld: main.o: in function `do_panic(int)':
/home/giuliobenetti/autobuild/run/instance-0/output-1/build/rtorrent-0.9.8/src/main.cc:606: undefined reference to `backtrace'
Fixes:
- http://autobuild.buildroot.org/results/10fc9016013931c58238240216c5950b23b56b30
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
35 lines
971 B
Diff
35 lines
971 B
Diff
From 582e4e40256b43d3e5322168f1e1ed71ca70ab64 Mon Sep 17 00:00:00 2001
|
|
From: rakshasa <sundell.software@gmail.com>
|
|
Date: Wed, 16 Jun 2021 23:29:01 +0900
|
|
Subject: [PATCH] Added '--disable-execinfo' option to configure.
|
|
|
|
[Retrieved (and backported) from:
|
|
https://github.com/rakshasa/rtorrent/commit/582e4e40256b43d3e5322168f1e1ed71ca70ab64]
|
|
Signed-off-by: Fabrice Fontaine <Fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 11 ++++++++++-
|
|
1 file changed, 10 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index e3e7d3f1..0f45bc6a 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -27,7 +27,15 @@ TORRENT_WITHOUT_VARIABLE_FDSET
|
|
|
|
AC_SYS_LARGEFILE
|
|
|
|
-TORRENT_CHECK_EXECINFO
|
|
+AC_ARG_ENABLE(execinfo,
|
|
+ AC_HELP_STRING([--disable-execinfo], [disable libexecinfo [[default=enable]]]),
|
|
+ [
|
|
+ if test "$enableval" = "yes"; then
|
|
+ TORRENT_CHECK_EXECINFO
|
|
+ fi
|
|
+ ],[
|
|
+ TORRENT_CHECK_EXECINFO
|
|
+ ])
|
|
|
|
TORRENT_ENABLE_ARCH
|
|
TORRENT_WITH_SYSROOT
|
|
|