42f19d49fb
This is a substantial update as the last time the midori version was bumped
was on Fri Apr 29 2016 commit 54bbd88b1f
.
Changes:
package/Config.in: Move midori out of the "X applications" submenu and into
the "Graphic applications" submenu, as it is not dependent on X.
- Drop the two existing patches as they no longer apply.
- 0001-disable-vala-fatal-warnings.patch: new patch. This patch fixes
errors when building midori in a buildroot source repository that is also
a git project.
- 0002-add-option-to-specify-path-to-g-ir-compiler.patchL new patch.
This patch introduces a new option that allows the make system to specify
a path to the g-ir-compiler, or else the host path's g-ir-compiler is used
which results in failed builds.
- Change the site to the github repository, as that is where the latest
releases are published.
- New dependencies: gobject-introspection, json-glib, libarchive, and libpeas.
- gcr is no longer an optional dependency.
- host-python3 is now a mandatory dependency.
Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
38 lines
1.3 KiB
Diff
38 lines
1.3 KiB
Diff
From 118ac24b2c488f490ee8814336291a58eae45395 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <aduskett@gmail.com>
|
|
Date: Tue, 12 Oct 2021 13:21:19 -0700
|
|
Subject: [PATCH] add option to specify path to g-ir-compiler
|
|
|
|
By default, find_program (GIR_COMPILER_BIN g-ir-compiler) returns the host path
|
|
to g-ir-compiler, which is undesirable in a cross-compile environment.
|
|
|
|
Add an option to manually specify a path to the g-ir-compiler.
|
|
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
---
|
|
core/CMakeLists.txt | 8 +++++++-
|
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
|
|
index c4982de..6584229 100644
|
|
--- a/core/CMakeLists.txt
|
|
+++ b/core/CMakeLists.txt
|
|
@@ -66,7 +66,13 @@ set_target_properties("${LIBCORE}" PROPERTIES
|
|
VERSION ${LIBCORE_VERSION}
|
|
)
|
|
|
|
-find_program (GIR_COMPILER_BIN g-ir-compiler)
|
|
+option(GIR_COMPILER_PATH "Specify a path to g-ir-compiler" OFF)
|
|
+if(GIR_COMPILER_PATH)
|
|
+ set(GIR_COMPILER_BIN "${GIR_COMPILER_PATH}")
|
|
+else()
|
|
+ find_program (GIR_COMPILER_BIN g-ir-compiler)
|
|
+endif(GIR_COMPILER_PATH)
|
|
+
|
|
add_custom_target(${LIBCORE_GIR}.typelib ALL
|
|
COMMAND ${GIR_COMPILER_BIN} ${CMAKE_CURRENT_BINARY_DIR}/${LIBCORE_GIR}.gir
|
|
--output ${CMAKE_CURRENT_BINARY_DIR}/${LIBCORE_GIR}.typelib
|
|
--
|
|
2.30.2
|
|
|