260e7fda6a
Disable tests to avoid the following static build failure on sh4aeb: In file included from /home/autobuild/autobuild/instance-5/output-1/build/libcgi-1.3.0/test/test_slist.c:20: /home/autobuild/autobuild/instance-5/output-1/build/libcgi-1.3.0/include/libcgi/cgi.h:81:31: note: expected 'char *' but argument is of type 'const char *' 81 | extern int slist_delete(char *name, formvars **start, formvars **last); | ~~~~~~^~~~ /home/autobuild/autobuild/instance-5/output-1/build/libcgi-1.3.0/test/test_slist.c:352:1: error: unable to find a register to spill in class 'FPUL_REGS' 352 | } | ^ /home/autobuild/autobuild/instance-5/output-1/build/libcgi-1.3.0/test/test_slist.c:352:1: error: this is the insn: (insn 1084 1081 1085 105 (set (reg:SI 4 r4) (mem/f:SI (post_inc:SI (reg:SI 76 fr12 [orig:343 ivtmp.286 ] [343])) [0 MEM[base: _414, offset: 0B]+0 S4 A32])) "/home/autobuild/autobuild/instance-5/output-1/build/libcgi-1.3.0/test/test_slist.c":323:3 189 {movsi_ie} (expr_list:REG_INC (reg:SI 76 fr12 [orig:343 ivtmp.286 ] [343]) (nil))) Fixes: - http://autobuild.buildroot.org/results/84a2339568d23b328af2416bfcec1ef41eccdce5 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
45 lines
1.2 KiB
Diff
45 lines
1.2 KiB
Diff
From 15ec267520efbe45193eb1df5361a4ab56164294 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Sun, 8 May 2022 17:54:42 +0200
|
|
Subject: [PATCH] CMakeLists.txt: honour BUILD_TESTING
|
|
|
|
Allow the user to disable tests through the standard BUILD_TESTING
|
|
option: https://cmake.org/cmake/help/latest/module/CTest.html
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Retrieved from:
|
|
https://github.com/rafaelsteil/libcgi/commit/15ec267520efbe45193eb1df5361a4ab56164294]
|
|
---
|
|
CMakeLists.txt | 12 +++++++++---
|
|
1 file changed, 9 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index cbf0d97..e3329a1 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -29,15 +29,21 @@ option(BUILD_SHARED_LIBS
|
|
"Global flag to cause add_library to create shared libraries if on."
|
|
ON
|
|
)
|
|
+option(BUILD_TESTING
|
|
+ "Build tests."
|
|
+ ON
|
|
+)
|
|
|
|
# subdirectories
|
|
add_subdirectory("include/libcgi")
|
|
add_subdirectory("src")
|
|
|
|
# test
|
|
-enable_testing()
|
|
-include(CTest)
|
|
-add_subdirectory("test")
|
|
+if(BUILD_TESTING)
|
|
+ enable_testing()
|
|
+ include(CTest)
|
|
+ add_subdirectory("test")
|
|
+endif(BUILD_TESTING)
|
|
|
|
# cmake package stuff
|
|
configure_package_config_file(${PROJECT_NAME_LC}-config.cmake.in
|