f02a0408dc
This patch bumps Samba version to 3.2.5. In the process Samba now depends on libiconv. This dependency is needed because Samba wants to use various formats when talking to the different parts of the system. Two new patches are introduced, one to double check if BSD functions are available, and one to skip checking for glibc version. The use unsigned enum patch could be removed since this can be supplied with a autoconf variable. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
42 lines
1.0 KiB
Diff
42 lines
1.0 KiB
Diff
--- a/source/configure.in
|
|
+++ b/source/configure.in
|
|
@@ -1182,38 +1182,6 @@ AC_TRY_COMPILE([
|
|
AC_DEFINE(HAVE_PRCTL, 1, [Whether prctl is available]),[])
|
|
|
|
#
|
|
-#
|
|
-#
|
|
-case "$host_os" in
|
|
- *linux*)
|
|
- # glibc <= 2.3.2 has a broken getgrouplist
|
|
- AC_TRY_RUN([
|
|
-#include <unistd.h>
|
|
-#include <sys/utsname.h>
|
|
-main() {
|
|
- /* glibc up to 2.3 has a broken getgrouplist */
|
|
-#if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
|
|
- int libc_major = __GLIBC__;
|
|
- int libc_minor = __GLIBC_MINOR__;
|
|
-
|
|
- if (libc_major < 2)
|
|
- exit(1);
|
|
- if ((libc_major == 2) && (libc_minor <= 3))
|
|
- exit(1);
|
|
-#endif
|
|
- exit(0);
|
|
-}
|
|
-], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
|
|
- if test x"$linux_getgrouplist_ok" = x"yes"; then
|
|
- AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
|
|
- fi
|
|
- ;;
|
|
- *)
|
|
- AC_CHECK_FUNCS(getgrouplist)
|
|
- ;;
|
|
-esac
|
|
-
|
|
-#
|
|
# stat64 family may need <sys/stat.h> on some systems, notably ReliantUNIX
|
|
#
|
|
|