9c13e02c35
Since the bump of libcap to 2.42, host-libcap unconditionally tries to build a shared library, which fails on build machines where the static version of the C library is not available. This issue was reported upstream, who fixed it by two different commits, which are backported as patches 0001 and 0002. They require passing a DYNAMIC= value, which should be "yes" to enable dynamic linking, or empty when not using dynamic linking. However, other upstream changes broke our logic to support static-only linking for the target. So we introduce a 0003 patch which extends how the DYNAMIC flag is used to disable the build of the shared library in the libcap/ folder. This allows to greatly simplify libcap.mk. Note that the refactoring is mixed with the fix: the two are hardly splitable. We need to be able to pass the same options at all steps, and especially the staging step, otherwise some code gets compiled with the host compiler, installed in staging, and thus fails the architecture check later on. Fixes: host-libcap build failure on system without a static libc http://autobuild.buildroot.net/results/4b14458014e420ffe088f118e7d0261e67f2d551/ libcap build failure on static only systems http://autobuild.buildroot.net/results/8961759067c4639ae697b6ee5db606f098b7c7e8/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> [yann.morin.1998@free.fr: - also pass DYNAMIC=yes at host-install step - extend commit log to explain why we refactor and fix together ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
37 lines
1.0 KiB
Diff
37 lines
1.0 KiB
Diff
From b7ca9dd97bbd9657c541f749ea6baf1f45b7c98a Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
Date: Wed, 9 Sep 2020 22:22:18 +0200
|
|
Subject: [PATCH] libcap/Makefile: disable building/installing shared
|
|
library when DYNAMIC is empty
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
---
|
|
libcap/Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libcap/Makefile b/libcap/Makefile
|
|
index 81b089e..dfd4dea 100644
|
|
--- a/libcap/Makefile
|
|
+++ b/libcap/Makefile
|
|
@@ -22,7 +22,7 @@ MAJLIBNAME=$(LIBNAME).$(VERSION)
|
|
MINLIBNAME=$(MAJLIBNAME).$(MINOR)
|
|
GPERF_OUTPUT = _caps_output.gperf
|
|
|
|
-all: $(MINLIBNAME) $(STACAPLIBNAME) pcs $(STAPSXLIBNAME)
|
|
+all: $(if $(DYNAMIC),$(MINLIBNAME)) $(STACAPLIBNAME) pcs $(STAPSXLIBNAME)
|
|
|
|
pcs: libcap.pc libpsx.pc
|
|
|
|
@@ -93,7 +93,7 @@ cap_test: cap_test.c libcap.h
|
|
test: cap_test
|
|
./cap_test
|
|
|
|
-install: install-shared install-static
|
|
+install: $(if $(DYNAMIC),install-shared) install-static
|
|
|
|
install-common: pcs
|
|
mkdir -p -m 0755 $(FAKEROOT)$(INCDIR)/sys
|
|
--
|
|
2.26.2
|
|
|