f0b00164ae
Fixes: - http://autobuild.buildroot.org/results/a6e64213f2910b2b81e79cb1e96e558413d7f70a Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
From fc25c5002cae23151309fce6059e230545fd4d82 Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Mon, 20 Apr 2020 21:20:19 +0200
|
|
Subject: [PATCH] Do not require C++ compiler for building
|
|
|
|
Fixes:
|
|
- http://autobuild.buildroot.org/results/a6e64213f2910b2b81e79cb1e96e558413d7f70a
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Retrieved from:
|
|
https://github.com/libfuse/libfuse/commit/fc25c5002cae23151309fce6059e230545fd4d82]
|
|
---
|
|
example/meson.build | 2 +-
|
|
meson.build | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/example/meson.build b/example/meson.build
|
|
index 3edddea9..2342df9c 100644
|
|
--- a/example/meson.build
|
|
+++ b/example/meson.build
|
|
@@ -31,7 +31,7 @@ foreach ex : threaded_examples
|
|
install: false)
|
|
endforeach
|
|
|
|
-if not platform.endswith('bsd') and platform != 'dragonfly'
|
|
+if not platform.endswith('bsd') and platform != 'dragonfly' and add_languages('cpp', required : false)
|
|
executable('passthrough_hp', 'passthrough_hp.cc',
|
|
dependencies: [ thread_dep, libfuse_dep ],
|
|
install: false)
|
|
diff --git a/meson.build b/meson.build
|
|
index 69b3630d..4428bdb9 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1,4 +1,4 @@
|
|
-project('libfuse3', ['cpp', 'c'], version: '3.9.1',
|
|
+project('libfuse3', ['c'], version: '3.9.1',
|
|
meson_version: '>= 0.42',
|
|
default_options: [ 'buildtype=debugoptimized' ])
|
|
|