cc28c7aa6d
- Update indentation in hash file (two spaces) - Disable w on musl to avoid a build failure: https://gitlab.com/procps-ng/procps/-/issues/193 https://gitlab.com/procps-ng/procps/-/blob/v3.3.17/NEWS Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
94 lines
2.0 KiB
Diff
94 lines
2.0 KiB
Diff
From 1524a625e693b956ce0b5091c9f89f24fb7e8614 Mon Sep 17 00:00:00 2001
|
|
From: "Issam E. Maghni" <issam.e.maghni@mailbox.org>
|
|
Date: Fri, 23 Apr 2021 15:58:36 -0400
|
|
Subject: [PATCH] configure: Add --disable-w
|
|
|
|
[Retrieved (and backported) from:
|
|
https://gitlab.com/procps-ng/procps/-/commit/1524a625e693b956ce0b5091c9f89f24fb7e8614]
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
Makefile.am | 21 +++++++++++++++------
|
|
configure.ac | 6 ++++++
|
|
2 files changed, 21 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index de15e137..d2356872 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -47,8 +47,7 @@ bin_PROGRAMS = \
|
|
pwdx \
|
|
tload \
|
|
uptime \
|
|
- vmstat \
|
|
- w
|
|
+ vmstat
|
|
if BUILD_PWAIT
|
|
bin_PROGRAMS += pwait
|
|
endif
|
|
@@ -60,8 +59,7 @@ usrbin_exec_PROGRAMS += \
|
|
pkill \
|
|
pmap \
|
|
uptime \
|
|
- vmstat \
|
|
- w
|
|
+ vmstat
|
|
endif
|
|
|
|
lib_LTLIBRARIES = \
|
|
@@ -74,7 +72,6 @@ dist_man_MANS = \
|
|
pmap.1 \
|
|
uptime.1 \
|
|
vmstat.8 \
|
|
- w.1 \
|
|
ps/procps.1
|
|
|
|
if !CYGWIN
|
|
@@ -137,6 +134,19 @@ else
|
|
EXTRA_DIST += kill.1
|
|
endif
|
|
|
|
+if BUILD_W
|
|
+if CYGWIN
|
|
+usrbin_exec_PROGRAMS += w
|
|
+else
|
|
+bin_PROGRAMS += w
|
|
+endif
|
|
+
|
|
+dist_man_MANS += w.1
|
|
+w_SOURCES = w.c lib/fileutils.c
|
|
+else
|
|
+ EXTRA_DIST += w.1
|
|
+endif
|
|
+
|
|
if WITH_NCURSES
|
|
if !CYGWIN
|
|
bin_PROGRAMS += \
|
|
@@ -213,7 +223,6 @@ endif
|
|
tload_SOURCES = tload.c lib/strutils.c lib/fileutils.c
|
|
uptime_SOURCES = uptime.c lib/fileutils.c
|
|
vmstat_SOURCES = vmstat.c lib/strutils.c lib/fileutils.c
|
|
-w_SOURCES = w.c lib/fileutils.c
|
|
|
|
# proc/libprocps.la
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 750c0fbb..3e83fb88 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -234,6 +234,12 @@ AC_ARG_ENABLE([kill],
|
|
[], [enable_kill=yes]
|
|
)
|
|
AM_CONDITIONAL(BUILD_KILL, test "x$enable_kill" = xyes)
|
|
+AC_ARG_ENABLE([w],
|
|
+ AS_HELP_STRING([--disable-w], [do not build w]),
|
|
+ [], [enable_w=yes]
|
|
+)
|
|
+AM_CONDITIONAL(BUILD_W, test "x$enable_w" = xyes)
|
|
+
|
|
AM_CONDITIONAL(LINUX, test "x$host_os" = xlinux-gnu)
|
|
AM_CONDITIONAL(CYGWIN, test "x$host_os" = xcygwin)
|
|
|
|
--
|
|
GitLab
|
|
|