kumquat-buildroot/package/efl/0001-evas-fix-compilation-with-Dwl-false.patch
Romain Naour 6deaa3d50d package/efl: bump to version 1.23.2
- Remove upstream patch [1].
- Switch to meson build system.
- The cryptography backend is now mandatory, use openssl for the host
  and use openssl by default for the target if gnutls is not selected.
- Add host-giflib since the dependency can't be disabled anymore.
  (even by adding gif in HOST_EFL_EVAS_LOADERS_DISABLER).
- Disable explicitely meson build options that was not previously handled
  (avahi, emotion, ecore-imf-loarders...)
- Elput support is now enabled through drm meson option [2], remove
  BR2_PACKAGE_EFL_ELPUT.
- Update license file hash (csharp licensing information, cxx bindings
  licensing)
- Add COPYING.images and licenses/COPYING.ASL license file.
- The evas png loader is now mandatory [3] (even by adding png in
  EFL_EVAS_LOADERS_DISABLER).
- Same for the evas gif loader [4].
- Backport an upstream patch to fix the evas build with -Dwl=false.
- Update indentation of hash file (two spaces)

See:
https://www.enlightenment.org/news/efl-1.23.0
https://www.enlightenment.org/news/efl-1.23.1
https://www.enlightenment.org/news/efl-1.23.2

[1] https://git.enlightenment.org/core/efl.git/commit/?id=c46a8143916f0d3f66bbdffc7107c97c88df212d
[2] https://git.enlightenment.org/core/efl.git/tree/meson.build?h=v1.23.3#n297
[3] https://git.enlightenment.org/core/efl.git/tree/src/modules/evas/meson.build?h=v1.23.3#n2
[4] https://git.enlightenment.org/core/efl.git/tree/src/modules/evas/meson.build?h=v1.23.3#n4

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-08-05 15:27:15 +02:00

32 lines
1.0 KiB
Diff

From e1c289912c4ad68380f8b317c6c91d25b5b73814 Mon Sep 17 00:00:00 2001
From: Boris Faure <billiob@gmail.com>
Date: Thu, 2 Jan 2020 11:38:31 +0000
Subject: [PATCH] evas: fix compilation with -Dwl=false
Reviewed-by: Chris Michael <cp.michael@samsung.com>
Reviewed-by: Marcel Hollerbach <mail@marcel-hollerbach.de>
Differential Revision: https://phab.enlightenment.org/D10994
(cherry picked from commit a2afcfc872c29bd2c4a60fdafbc655c90f938d1e)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
src/modules/evas/engines/gl_drm/evas_engine.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/modules/evas/engines/gl_drm/evas_engine.c b/src/modules/evas/engines/gl_drm/evas_engine.c
index a5b4c7a4c8..8c1d6013e7 100644
--- a/src/modules/evas/engines/gl_drm/evas_engine.c
+++ b/src/modules/evas/engines/gl_drm/evas_engine.c
@@ -3,8 +3,6 @@
#include "../gl_common/evas_gl_define.h"
#include "../software_generic/evas_native_common.h"
-#include <wayland-client.h>
-
#ifdef HAVE_DLSYM
# include <dlfcn.h> /* dlopen,dlclose,etc */
#else
--
2.24.1