kumquat-buildroot/package/uclibc/0.9.33.2/uclibc-0060-test-Fix-math-c-dependency.patch
Alexey Brodkin 8fa35b77f7 uclibc: fix tests building in uClibc 0.9.33.2
Following patches are required for successful bulding of uClibc built-int tests
(BR2_UCLIBC_INSTALL_TEST_SUITE=y):

1.
uclibc-0059-test-cater-for-config.patch
http://git.uclibc.org/uClibc/commit/test?id=7598eeaa1defa2884adaa890bb115c493d69cc35

2.
uclibc-0058-test-tls-fix-build-with-newer-binutils.patch
http://git.uclibc.org/uClibc/commit/test?id=931e8391565323ed2e589c83b83a7345813a5514

3.
uclibc-0060-test-Fix-math-c-dependency.patch
http://git.uclibc.org/uClibc/commit/test/math?id=a20a91ad7c042c46e4a2adee6d03315f857f9985

All mentioned patches must be removed as obsolete on bumping uClibc to the next
release.

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>

Cc: Anton Kolesov <akolesov@synopsys.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2014-07-15 23:06:11 +02:00

31 lines
945 B
Diff

From a20a91ad7c042c46e4a2adee6d03315f857f9985 Mon Sep 17 00:00:00 2001
From: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Date: Tue, 18 Feb 2014 23:30:28 +0100
Subject: [PATCH] test: Fix math .c dependency
When explicitly running the compile target we were missing a dependency
to generate the libm-test.c.
Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
---
test/math/Makefile.in | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/test/math/Makefile.in b/test/math/Makefile.in
index beef650..0285b66 100644
--- a/test/math/Makefile.in
+++ b/test/math/Makefile.in
@@ -25,7 +25,8 @@ EXTRA_LDFLAGS := -lm
PERL := /usr/bin/perl
-$(TESTS): libm-test.c
+MDEPS := $(wildcard test-*.c)
+$(MDEPS): libm-test.c
libm-test.c: libm-test-ulps-$(TARGET_ARCH) libm-test.inc gen-libm-test.pl
$(Q)$(PERL) ./gen-libm-test.pl -u libm-test-ulps-$(TARGET_ARCH) ./libm-test.inc -o "." 2>&1 > /dev/null
--
1.9.3