kumquat-buildroot/package/usb_modeswitch/usb_modeswitch-1.0.7-build-system-fix.patch
Thomas Petazzoni 6caec6f3b3 usb_modeswitch: use GENTARGETS instead of AUTOTARGETS
usb_modeswitch build system is just a simple Makefile, so the
GENTARGETS infrastructure is more appropriate than the AUTOTARGETS
infrastructure. The build system is slightly fixed through a small
patch, that replaces the previous "nostrip" patch.

The latest version of usb_modeswitch is 1.1.1, but it now relies on
udev and requires TCL to operate. Someone actually using
usb_modeswitch would probably be at a better place to do this version
bump.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2010-04-06 21:55:30 +02:00

30 lines
758 B
Diff

---
Makefile | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
Index: usb_modeswitch-1.0.7/Makefile
===================================================================
--- usb_modeswitch-1.0.7.orig/Makefile
+++ usb_modeswitch-1.0.7/Makefile
@@ -1,8 +1,8 @@
PROG = usb_modeswitch
VERS = 1.0.7
STRIP = strip
-CC = gcc
-CCFLAGS = -l usb -Wall
+CC ?= gcc
+CFLAGS += -l usb -Wall
RM = /bin/rm -f
OBJS = usb_modeswitch.c
PREFIX = $(DESTDIR)/usr
@@ -12,8 +12,7 @@
.PHONY: clean
all: $(PROG)
$(PROG): $(OBJS)
- $(CC) $(CCFLAGS) -o $(PROG) $(OBJS)
- $(STRIP) $(PROG)
+ $(CC) $(CFLAGS) -o $(PROG) $(OBJS)
clean:
$(RM) ./usb_modeswitch