5364b22b6c
This commit mainly fixes bug #7268 by improving the isolation of the build environment by making sure some host environment header paths do not leak into the target build. The investigation was done by David <buildroot-2014@inbox.com>. This is done by not calling the add_multiarch_paths() function of setup.py when we're cross-compiling, a change made in the newly introduced python3-012-dont-add-multiarch-path.patch. In addition to this, another patch is added to make sure the build is aborted when one of the Python module fails to build. This is done in python3-013-abort-on-failed-modules.patch. Without this, the Python setup.py script simply logs which module failed to build, but doesn't abort, so it's hard to notice when there is a problem. [Peter: slightly reword commit message] Cc: David <buildroot-2014@inbox.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
29 lines
1.1 KiB
Diff
29 lines
1.1 KiB
Diff
Don't add multiarch paths
|
|
|
|
The add_multiarch_paths() function leads, in certain build
|
|
environments, to the addition of host header paths to the CFLAGS,
|
|
which is not appropriate for cross-compilation. This patch fixes that
|
|
by simply removing the call to add_multiarch_paths() when we're
|
|
cross-compiling.
|
|
|
|
Investigation done by David <buildroot-2014@inbox.com>.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/setup.py
|
|
===================================================================
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -461,10 +461,10 @@
|
|
if not cross_compiling:
|
|
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
+ self.add_multiarch_paths()
|
|
# only change this for cross builds for 3.3, issues on Mageia
|
|
if cross_compiling:
|
|
self.add_gcc_paths()
|
|
- self.add_multiarch_paths()
|
|
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
# CPPFLAGS for header and library files.
|