f26ce57760
Minimal rebase of patches on 3.9.0. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
40 lines
1.5 KiB
Diff
40 lines
1.5 KiB
Diff
From e4ae670e3489544a49dabd1618c32fe73504a7ba Mon Sep 17 00:00:00 2001
|
|
From: Samuel Cabrero <samuelcabrero@gmail.com>
|
|
Date: Wed, 23 Dec 2015 11:45:48 +0100
|
|
Subject: [PATCH] Override system locale and set to default when adding gcc
|
|
paths
|
|
|
|
Forces the use of the default locale in the function
|
|
add_gcc_paths, which is called when cross compiling to add the
|
|
include and library paths. This is necessary because otherwise
|
|
the gcc output is localized and the output parsing fails, which
|
|
results in no paths added and detect_modules not able to find
|
|
any system library (eg. libz, libssl, etc.)
|
|
|
|
[Thomas: patch taken from https://bugs.python.org/issue23767.]
|
|
|
|
Signed-off-by: Samuel Cabrero <samuelcabrero@gmail.com>
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
[james.hilliard1@gmail.com: adapt to python 3.9]
|
|
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index d3f0e663f2..926c16f58f 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -695,7 +695,7 @@ class PyBuildExt(build_ext):
|
|
tmpfile = os.path.join(self.build_temp, 'ccpaths')
|
|
if not os.path.exists(self.build_temp):
|
|
os.makedirs(self.build_temp)
|
|
- ret = run_command('%s -E -v - </dev/null 2>%s 1>/dev/null' % (cc, tmpfile))
|
|
+ ret = run_command('LC_ALL=C %s -E -v - </dev/null 2>%s 1>/dev/null' % (cc, tmpfile))
|
|
is_gcc = False
|
|
is_clang = False
|
|
in_incdirs = False
|
|
--
|
|
2.25.1
|
|
|