01dfbb48c5
lua-periphery currently clones and builds the c-periphery library by itself. This causes two problems: 1/ It does not integrate properly with the download infrastructure of Buildroot, making offline builds impossible since not the entire source code is downloaded by Buildroot. 2/ It does not use the latest version of c-periphery, which has some fixes contributed by Vicente to fix c-periphery on MIPS. This commit fixes: http://autobuild.buildroot.org/results/0ad/0ad656970b3cbc84b5531b28155ba2f747715fe3/ [Peter: fix minor typo in patch 0001 description] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
33 lines
1.0 KiB
Diff
33 lines
1.0 KiB
Diff
From 395bb4cb37612a4ac94346531b13ff0e901ed05e Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 5 May 2015 23:59:17 +0200
|
|
Subject: [PATCH 1/2] Makefile: don't clone/build c-periphery
|
|
|
|
This patch adjusts lua-periphery Makefile to not clone and build the
|
|
c-periphery library by itself, and instead use the already available
|
|
c-periphery library.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/lua-periphery/Makefile b/lua-periphery/Makefile
|
|
index bed9b32..a4c68eb 100644
|
|
--- a/lua-periphery/Makefile
|
|
+++ b/lua-periphery/Makefile
|
|
@@ -36,8 +36,8 @@ install:
|
|
|
|
###########################################################################
|
|
|
|
-$(LIB): $(C_PERIPHERY_LIB) $(SRCS)
|
|
- $(CC) $(CFLAGS) $(LDFLAGS) $(SRCS) $(C_PERIPHERY_LIB) -o $@
|
|
+$(LIB): $(SRCS)
|
|
+ $(CC) $(CFLAGS) $(LDFLAGS) $(SRCS) -lc-periphery -o $@
|
|
|
|
$(C_PERIPHERY_LIB): $(C_PERIPHERY)/Makefile
|
|
cd $(C_PERIPHERY); $(MAKE)
|
|
--
|
|
2.1.0
|
|
|