b766ed21e8
gcc 4.6 has stricter checks for invalid command-line options. Fix compilation by passing linker options with -Wl, Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
16 lines
623 B
Diff
16 lines
623 B
Diff
Fix compilation with gcc 4.6 by correcting the way that linker options
|
|
are passed to gcc.
|
|
|
|
Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
|
|
--- kexec-2.0.2/purgatory/Makefile.orig 2011-09-26 14:16:44.256595912 +0200
|
|
+++ kexec-2.0.2/purgatory/Makefile 2011-09-26 14:17:01.606621357 +0200
|
|
@@ -56,7 +56,7 @@
|
|
-I$(srcdir)/include \
|
|
-I$(shell $(CC) -print-file-name=include)
|
|
$(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\
|
|
- --no-undefined -nostartfiles -nostdlib -nodefaultlibs \
|
|
+ -Wl,-no-undefined -nostartfiles -nostdlib -nodefaultlibs \
|
|
-e purgatory_start -r
|
|
|
|
$(PURGATORY): $(PURGATORY_OBJS)
|