63aeae6538
This refreshes the set of python3 patches so they apply cleanly on the v3.5.2 tag of cpython Github repository. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
From f33d59b67f26649babc8c91e38eff9bc817d0470 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:45:13 +0100
|
|
Subject: [PATCH] Do not harcode invalid path to ncursesw headers
|
|
|
|
Adding /usr/include/ncursesw is obviously invalid when
|
|
cross-compiling. Since the ncursesw headers are no longer installed in
|
|
usr/include/ncursesw/, but directly in usr/include, there is anyway no
|
|
need for a special header path.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index d02012d..cc2f00b 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -1326,7 +1326,6 @@ class PyBuildExt(build_ext):
|
|
panel_library = 'panel'
|
|
if curses_library == 'ncursesw':
|
|
curses_defines.append(('HAVE_NCURSESW', '1'))
|
|
- curses_includes.append('/usr/include/ncursesw')
|
|
# Bug 1464056: If _curses.so links with ncursesw,
|
|
# _curses_panel.so must link with panelw.
|
|
panel_library = 'panelw'
|
|
--
|
|
2.7.4
|
|
|