kumquat-buildroot/package/apr/0001-sys-param-h.patch
Peter Seiderer 783cd8d90d package/apr: security bump version to 1.7.2
- remove 0001-cross-compile.patch
  (superseded by upstream commit [1])

- rename 0002-sys-param-h.patch to 0001-sys-param-h.patch

- remove 0003-Merge-r1887279-from-trunk.patch
  (from upstream [2])

- remove 0004-apr-1.7.0-CVE-2021-35940.patch
  (superseded by upstream commit [3], remove APR_IGNORE_CVES accordingly)

- set new configure option '--disable-sctp' (no libsctp provided by buildroot)

- set new 'ac_cv_strerror_r_rc_int' explicitly to no (default for
  cross compile)

- set new 'ac_cv_mmap__dev_zero' explicitly to yes

- revert two upstream commits ([4], [5]) to fix apr-util build, fails
  otherwise because of some path mismatch where to find apr_rules.mk copied
  to apr-util-1.6.3/build/rules.mk, fixes:

    Makefile:50: .../build/apr-util-1.6.3/build/rules.mk: No such file or directory

For details see [6].

[1] 866e1df66b
[2] 0a763c5e50
[3] e0be630b68
[4] f82374627b
[5] b6dbbc77da
[6] https://downloads.apache.org/apr/CHANGES-APR-1.7

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2023-03-02 23:19:55 +01:00

40 lines
1.3 KiB
Diff

Fix PATH_MAX detection by including sys/param.h if available
Patch sent upstream:
https://bz.apache.org/bugzilla/show_bug.cgi?id=63782
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
diff -uNr apr-1.7.0.orig/configure.in apr-1.7.0/configure.in
--- apr-1.7.0.orig/configure.in 2019-04-01 19:40:46.000000000 +0200
+++ apr-1.7.0/configure.in 2019-09-29 17:03:41.803326791 +0200
@@ -1586,6 +1586,7 @@
AC_SUBST(stringh)
AC_SUBST(stringsh)
AC_SUBST(sys_ioctlh)
+AC_SUBST(sys_paramh)
AC_SUBST(sys_sendfileh)
AC_SUBST(sys_signalh)
AC_SUBST(sys_socketh)
diff -uNr apr-1.7.0.orig/include/apr.h.in apr-1.7.0/include/apr.h.in
--- apr-1.7.0.orig/include/apr.h.in 2019-03-22 14:30:31.000000000 +0100
+++ apr-1.7.0/include/apr.h.in 2019-09-29 17:04:54.203815469 +0200
@@ -95,6 +95,7 @@
#define APR_HAVE_STRINGS_H @stringsh@
#define APR_HAVE_INTTYPES_H @inttypesh@
#define APR_HAVE_SYS_IOCTL_H @sys_ioctlh@
+#define APR_HAVE_SYS_PARAM_H @sys_paramh@
#define APR_HAVE_SYS_SENDFILE_H @sys_sendfileh@
#define APR_HAVE_SYS_SIGNAL_H @sys_signalh@
#define APR_HAVE_SYS_SOCKET_H @sys_socketh@
@@ -206,6 +207,9 @@
#include <sys/syslimits.h>
#endif
#endif
+#if APR_HAVE_SYS_PARAM_H
+#include <sys/param.h>
+#endif
/* __APPLE__ is now the official pre-defined macro for macOS */
#ifdef __APPLE__