897d07c313
Note that we don't use completely sequential numbers, because patches below 100 are used to address cross-compilation issues in Python, while patches above 100 are used to make more Python modules configurable. [Thomas: fixup commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
31 lines
1.3 KiB
Diff
31 lines
1.3 KiB
Diff
Remove the python symlink install rules.
|
|
|
|
The python symlink installation will be handled by Buildroot itself, because
|
|
Buildroot needs to control to what python interpreter (python2 or python3) the
|
|
python symlink points to.
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
|
|
Index: b/Makefile.pre.in
|
|
===================================================================
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -890,17 +890,10 @@
|
|
# $(PYTHON) -> python2 -> python$(VERSION))
|
|
# Also create equivalent chains for other installed files
|
|
bininstall: altbininstall
|
|
- -if test -f $(DESTDIR)$(BINDIR)/$(PYTHON) -o -h $(DESTDIR)$(BINDIR)/$(PYTHON); \
|
|
- then rm -f $(DESTDIR)$(BINDIR)/$(PYTHON); \
|
|
- else true; \
|
|
- fi
|
|
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python2$(EXE) $(PYTHON))
|
|
-rm -f $(DESTDIR)$(BINDIR)/python2$(EXE)
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python2$(EXE))
|
|
-rm -f $(DESTDIR)$(BINDIR)/python2-config
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python2-config)
|
|
- -rm -f $(DESTDIR)$(BINDIR)/python-config
|
|
- (cd $(DESTDIR)$(BINDIR); $(LN) -s python2-config python-config)
|
|
-test -d $(DESTDIR)$(LIBPC) || $(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC)
|
|
-rm -f $(DESTDIR)$(LIBPC)/python2.pc
|
|
(cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python2.pc)
|