c14fb7c1dd
We were patching m4/rename.m4 to workaround an upstream issue, but this triggers a auto* rebuild and a configure rerun when we build coreutils using whatever auto* versions the user has installed. Doing a manual autoreconf run after patching is unfortunately not an option as the coreutils configure.ac isn't compatible with the autotools version we have in BR. Instead, simply cheat by patching configure as well and setting the timestamp of m4/rename.m4 sufficiently far back to ensure make doesn't consider ./configure out of date. Long term we should convert coreutils to Makefile.autotools.in format, but this is good enought for 2009.11. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
45 lines
1.7 KiB
Diff
45 lines
1.7 KiB
Diff
Commit 7fcb389fb4cd5ba26e330fef991ffdc05392f289 from gnulib, to fix
|
|
the rename bugs detection macros.
|
|
---
|
|
m4/rename.m4 | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
Index: coreutils-7.4/m4/rename.m4
|
|
===================================================================
|
|
--- coreutils-7.4.orig/m4/rename.m4
|
|
+++ coreutils-7.4/m4/rename.m4
|
|
@@ -51,12 +51,12 @@
|
|
AC_LIBOBJ([rename])
|
|
AC_DEFINE([rename], [rpl_rename],
|
|
[Define to rpl_rename if the replacement function should be used.])
|
|
- if test $gl_cv_func_rename_trailing_slash_bug; then
|
|
+ if test $gl_cv_func_rename_trailing_slash_bug = yes; then
|
|
AC_DEFINE([RENAME_TRAILING_SLASH_BUG], [1],
|
|
[Define if rename does not work for source file names with a trailing
|
|
slash, like the one from SunOS 4.1.1_U1.])
|
|
fi
|
|
- if test $gl_cv_func_rename_dest_exists_bug; then
|
|
+ if test $gl_cv_func_rename_dest_exists_bug = yes; then
|
|
AC_DEFINE([RENAME_DEST_EXISTS_BUG], [1],
|
|
[Define if rename does not work when the destination file exists,
|
|
as on Windows.])
|
|
Index: coreutils-7.4/configure
|
|
===================================================================
|
|
--- coreutils-7.4.orig/configure
|
|
+++ coreutils-7.4/configure
|
|
@@ -28698,12 +28698,12 @@ $as_echo "$gl_cv_func_rename_dest_exists
|
|
|
|
$as_echo "#define rename rpl_rename" >>confdefs.h
|
|
|
|
- if test $gl_cv_func_rename_trailing_slash_bug; then
|
|
+ if test $gl_cv_func_rename_trailing_slash_bug = yes; then
|
|
|
|
$as_echo "#define RENAME_TRAILING_SLASH_BUG 1" >>confdefs.h
|
|
|
|
fi
|
|
- if test $gl_cv_func_rename_dest_exists_bug; then
|
|
+ if test $gl_cv_func_rename_dest_exists_bug = yes; then
|
|
|
|
$as_echo "#define RENAME_DEST_EXISTS_BUG 1" >>confdefs.h
|
|
|