37c739f226
Needed by the bump of xapp_clipboard, itself needed to avoid the following build failure: http://autobuild.buildroot.org/results/1a4f84ad76ad8c4e70bff6878fc232edf46ff8f1/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
51 lines
1.4 KiB
Diff
51 lines
1.4 KiB
Diff
From 3f064076c783914cafdff028db303681dae4291d Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Thu, 15 Nov 2012 18:31:53 +0100
|
|
Subject: [PATCH] libXt: util: don't link makestrs with target cflags
|
|
|
|
The line:
|
|
|
|
AM_CFLAGS = $(XT_CFLAGS)
|
|
|
|
in util/Makefile.am is wrong because it adds target cflags to the
|
|
compilation of makestrs, which is built for the build machine, which
|
|
leads to build failures when cross-compiling.
|
|
|
|
We also remove the inclusion of <X11/Xos.h> from makestrs.c, because
|
|
it was the only non-standard header being included (and therefore
|
|
possibly requiring special cflags), but it was in reality not useful
|
|
at all to build makestrs.c.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
util/Makefile.am | 1 -
|
|
util/makestrs.c | 1 -
|
|
2 files changed, 2 deletions(-)
|
|
|
|
diff --git a/util/Makefile.am b/util/Makefile.am
|
|
index dedfa6b..cc6f3fc 100644
|
|
--- a/util/Makefile.am
|
|
+++ b/util/Makefile.am
|
|
@@ -10,7 +10,6 @@ EXTRA_DIST = \
|
|
StrDefs.ht \
|
|
string.list
|
|
|
|
-AM_CFLAGS = $(XT_CFLAGS)
|
|
makestrs_SOURCES = makestrs.c
|
|
|
|
|
|
diff --git a/util/makestrs.c b/util/makestrs.c
|
|
index a52866a..00c861f 100644
|
|
--- a/util/makestrs.c
|
|
+++ b/util/makestrs.c
|
|
@@ -27,7 +27,6 @@ in this Software without prior written authorization from The Open Group.
|
|
/* Constructs string definitions */
|
|
|
|
#include <stdio.h>
|
|
-#include <X11/Xos.h>
|
|
#include <stdlib.h>
|
|
#include <unistd.h>
|
|
|
|
--
|
|
1.7.9.5
|