25b1fc2898
- Remove 0013-Add-an-option-to-disable-installation-of-test-module.patch as it is now upstreamed. - Refactor and rename all other patches as necessary. Signed-off-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
38 lines
1.3 KiB
Diff
38 lines
1.3 KiB
Diff
From f5933b8f973cd11698b52d535a10d0474e49f5a5 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:36:27 +0100
|
|
Subject: [PATCH] Don't add multiarch paths
|
|
|
|
The add_multiarch_paths() function leads, in certain build
|
|
environments, to the addition of host header paths to the CFLAGS,
|
|
which is not appropriate for cross-compilation. This patch fixes that
|
|
by simply removing the call to add_multiarch_paths() when we're
|
|
cross-compiling.
|
|
|
|
Investigation done by David <buildroot-2014@inbox.com>.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index ec3ba60607..e27620035c 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -830,10 +830,10 @@ class PyBuildExt(build_ext):
|
|
if not CROSS_COMPILING:
|
|
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
+ self.add_multiarch_paths()
|
|
# only change this for cross builds for 3.3, issues on Mageia
|
|
if CROSS_COMPILING:
|
|
self.add_cross_compiling_paths()
|
|
- self.add_multiarch_paths()
|
|
self.add_ldflags_cppflags()
|
|
|
|
def init_inc_lib_dirs(self):
|
|
--
|
|
2.25.1
|
|
|