e821078031
A library to control commonly available 64x64, 32x32 or 16x32 RGB LED panels with the Raspberry Pi. Can support PWM up to 11Bit per channel, providing true 24bpp color with CIE1931 profile. Signed-off-by: Grzegorz Blach <grzegorz@blach.pl> [Arnout: reorder build/install hooks inside conditions] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
47 lines
1.7 KiB
Diff
47 lines
1.7 KiB
Diff
From 056a189836a82b832cd8e6f886cb2090344bfa08 Mon Sep 17 00:00:00 2001
|
|
From: Grzegorz Blach <grzegorz@blach.pl>
|
|
Date: Sat, 29 Aug 2020 20:48:57 +0200
|
|
Subject: [PATCH] Rename LDFLAGS to RGB_LDFLAGS.
|
|
|
|
This change allows additional flags to be added to the linker
|
|
from the command line.
|
|
|
|
Signed-off-by: Grzegorz Blach <grzegorz@blach.pl>
|
|
---
|
|
utils/Makefile | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/utils/Makefile b/utils/Makefile
|
|
index e751adc..e704442 100644
|
|
--- a/utils/Makefile
|
|
+++ b/utils/Makefile
|
|
@@ -12,7 +12,7 @@ RGB_INCDIR=$(RGB_LIB_DISTRIBUTION)/include
|
|
RGB_LIBDIR=$(RGB_LIB_DISTRIBUTION)/lib
|
|
RGB_LIBRARY_NAME=rgbmatrix
|
|
RGB_LIBRARY=$(RGB_LIBDIR)/lib$(RGB_LIBRARY_NAME).a
|
|
-LDFLAGS+=-L$(RGB_LIBDIR) -l$(RGB_LIBRARY_NAME) -lrt -lm -lpthread
|
|
+RGB_LDFLAGS+=-L$(RGB_LIBDIR) -l$(RGB_LIBRARY_NAME) -lrt -lm -lpthread
|
|
|
|
# Imagemagic flags, only needed if actually compiled.
|
|
MAGICK_CXXFLAGS?=$(shell GraphicsMagick++-config --cppflags --cxxflags)
|
|
@@ -28,13 +28,13 @@ $(RGB_LIBRARY): FORCE
|
|
$(MAKE) -C $(RGB_LIBDIR)
|
|
|
|
text-scroller: text-scroller.o $(RGB_LIBRARY)
|
|
- $(CXX) $(CXXFLAGS) text-scroller.o -o $@ $(LDFLAGS)
|
|
+ $(CXX) $(CXXFLAGS) text-scroller.o -o $@ $(LDFLAGS) $(RGB_LDFLAGS)
|
|
|
|
led-image-viewer: led-image-viewer.o $(RGB_LIBRARY)
|
|
- $(CXX) $(CXXFLAGS) led-image-viewer.o -o $@ $(LDFLAGS) $(MAGICK_LDFLAGS)
|
|
+ $(CXX) $(CXXFLAGS) led-image-viewer.o -o $@ $(LDFLAGS) $(RGB_LDFLAGS) $(MAGICK_LDFLAGS)
|
|
|
|
video-viewer: video-viewer.o $(RGB_LIBRARY)
|
|
- $(CXX) $(CXXFLAGS) video-viewer.o -o $@ $(LDFLAGS) $(AV_LDFLAGS)
|
|
+ $(CXX) $(CXXFLAGS) video-viewer.o -o $@ $(LDFLAGS) $(RGB_LDFLAGS) $(AV_LDFLAGS)
|
|
|
|
%.o : %.cc
|
|
$(CXX) -I$(RGB_INCDIR) $(CXXFLAGS) -c -o $@ $<
|
|
--
|
|
2.24.3 (Apple Git-128)
|
|
|