0f57fcb91b
Version 2.3 is unmaintained: http://article.gmane.org/gmane.comp.video.ffmpeg.devel/183038 - removed ffmpeg-0002-bfin.patch, applied upstream - added vlc-0004-libav.patch from upstream to fix VLC compilation Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
23 lines
1.1 KiB
Diff
23 lines
1.1 KiB
Diff
VLC works fine with ffmpeg 2.4, ported from upstream
|
|
http://git.videolan.org/?p=vlc/vlc-2.2.git;a=blobdiff;f=configure.ac;h=21a9f89585297ebb98481a29719ef35a20f040db;hp=570da72136f4a5f8142fbab696ece53dd7f84b6a;hb=4ed2079b77b8aeb6d7885cc9828a90290018a7a4;hpb=18fbf7fd17a0f4e9cabcc2e34ac54b210ba08b27
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 570da72..21a9f89 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2285,9 +2285,9 @@ AC_ARG_ENABLE(avcodec,
|
|
[ --enable-avcodec libavcodec codec (default enabled)])
|
|
AS_IF([test "${enable_avcodec}" != "no"], [
|
|
PKG_CHECK_MODULES(AVCODEC,[libavcodec >= 53.34.0 libavutil >= 51.22.0], [
|
|
- PKG_CHECK_EXISTS([libavcodec < 56],, [
|
|
- AC_MSG_ERROR([libavcodec versions 56 and later are not supported yet.])
|
|
- ])
|
|
+ dnl PKG_CHECK_EXISTS([libavcodec < 56],, [
|
|
+ dnl AC_MSG_ERROR([libavcodec versions 56 and later are not supported yet.])
|
|
+ dnl ])
|
|
VLC_SAVE_FLAGS
|
|
CPPFLAGS="${CPPFLAGS} ${AVCODEC_CFLAGS}"
|
|
CFLAGS="${CFLAGS} ${AVCODEC_CFLAGS}"
|