ce81a6e6d2
Drop 0030-Fix-cross-compiling-the-uuid-module.patch as the patched code has been reworked upstream and python3 is built with --disable-uuid:91a51c5ffc
Rework 0033-configure.ac-fixup-CC-print-multiarch-output-for-mus.patch as the MULTIARCH code is now conditional on !darwin:9901d153c2
Refresh and renumber remaining patches. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
43 lines
1.2 KiB
Diff
43 lines
1.2 KiB
Diff
From 4d87cebaff75a19cd7ccf20f1c89abec5a5bce8d Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 7 Mar 2017 23:31:11 +0100
|
|
Subject: [PATCH] Add options to disable zlib, bzip2 and xz modules
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
configure.ac | 18 ++++++++++++++++++
|
|
1 file changed, 18 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index d5732b2474..3eadf17306 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3425,6 +3425,24 @@ AC_ARG_ENABLE(readline,
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} readline"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(bzip2,
|
|
+ AS_HELP_STRING([--disable-bzip2], [disable bzip2]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _bz2"
|
|
+ fi])
|
|
+
|
|
+AC_ARG_ENABLE(zlib,
|
|
+ AS_HELP_STRING([--disable-zlib], [disable zlib]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} zlib"
|
|
+ fi])
|
|
+
|
|
+AC_ARG_ENABLE(xz,
|
|
+ AS_HELP_STRING([--disable-xz], [disable xz]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _lzma"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(TK)
|
|
AC_ARG_ENABLE(tk,
|
|
AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
--
|
|
2.20.1
|
|
|