ce81a6e6d2
Drop 0030-Fix-cross-compiling-the-uuid-module.patch as the patched code has been reworked upstream and python3 is built with --disable-uuid:91a51c5ffc
Rework 0033-configure.ac-fixup-CC-print-multiarch-output-for-mus.patch as the MULTIARCH code is now conditional on !darwin:9901d153c2
Refresh and renumber remaining patches. Signed-off-by: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
38 lines
1.3 KiB
Diff
38 lines
1.3 KiB
Diff
From e87dececb9bc2f4b1cba7f31d67ca2aaecbb52d8 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Wed, 23 Dec 2015 11:36:27 +0100
|
|
Subject: [PATCH] Don't add multiarch paths
|
|
|
|
The add_multiarch_paths() function leads, in certain build
|
|
environments, to the addition of host header paths to the CFLAGS,
|
|
which is not appropriate for cross-compilation. This patch fixes that
|
|
by simply removing the call to add_multiarch_paths() when we're
|
|
cross-compiling.
|
|
|
|
Investigation done by David <buildroot-2014@inbox.com>.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 254c351519..5bf39f8a51 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -737,10 +737,10 @@ class PyBuildExt(build_ext):
|
|
if not CROSS_COMPILING:
|
|
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
+ self.add_multiarch_paths()
|
|
# only change this for cross builds for 3.3, issues on Mageia
|
|
if CROSS_COMPILING:
|
|
self.add_cross_compiling_paths()
|
|
- self.add_multiarch_paths()
|
|
self.add_ldflags_cppflags()
|
|
|
|
def init_inc_lib_dirs(self):
|
|
--
|
|
2.20.1
|
|
|