4d6b8ea78d
Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
27 lines
822 B
Diff
27 lines
822 B
Diff
From 875fcad2ad84877763cba86c1265b57679b878b0 Mon Sep 17 00:00:00 2001
|
|
From: Peter Seiderer <ps.report@gmx.net>
|
|
Date: Tue, 24 Oct 2017 16:58:32 +0200
|
|
Subject: [PATCH] Reproducible build: do not leak compiler path
|
|
|
|
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
|
---
|
|
crypto/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/crypto/Makefile b/crypto/Makefile
|
|
index 7869996..7e63291 100644
|
|
--- a/crypto/Makefile
|
|
+++ b/crypto/Makefile
|
|
@@ -55,7 +55,7 @@ top:
|
|
all: shared
|
|
|
|
buildinf.h: ../Makefile
|
|
- $(PERL) $(TOP)/util/mkbuildinf.pl "$(CC) $(CFLAGS)" "$(PLATFORM)" >buildinf.h
|
|
+ $(PERL) $(TOP)/util/mkbuildinf.pl "$$(basename $(CC)) $(CFLAGS)" "$(PLATFORM)" >buildinf.h
|
|
|
|
x86cpuid.s: x86cpuid.pl perlasm/x86asm.pl
|
|
$(PERL) x86cpuid.pl $(PERLASM_SCHEME) $(CFLAGS) $(PROCESSOR) > $@
|
|
--
|
|
2.11.0
|
|
|