kumquat-buildroot/package/wpa_supplicant/0006-fix-libwpa_client.patch
Jörg Krause 4e793b82a5 package/wpa_supplicant: add config option to build wpa_client library
Version 2.5 of wpa_supplicant introduces the config option
CONFIG_BUILD_WPA_CLIENT_SO to enable building wpa_client as shared library.

We need to add a patch from upstream to fix a runtime error with
libwpa_client.so:
  Error relocating /usr/lib/libwpa_client.so: bin_clear_free: symbol not found

[Thomas: renumber patch.]

Cc: Martin Bark <martin@barkynet.com>
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Reviewed-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-12-20 15:07:56 +01:00

40 lines
1.2 KiB
Diff

From 6f7e0354a9035ce33742a5f869f817a6b39b2f31 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
Date: Thu, 29 Oct 2015 11:39:03 +0100
Subject: [PATCH 1/1] wpa_supplicant/Makefile: fix libwpa_client
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Building libwpa_client requires src/utils/common.c for bin_clear_free() else
loading the library fails with:
Error relocating /usr/lib/libwpa_client.so: bin_clear_free: symbol not found
Backported from: 736b7cb2daf877a0cb9ad42ff15a2efbbd65fa42
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
wpa_supplicant/Makefile | 2 ++
1 file changed, 2 insertions(+)
diff --git a/wpa_supplicant/Makefile b/wpa_supplicant/Makefile
index 61f8f18..0c444b0 100644
--- a/wpa_supplicant/Makefile
+++ b/wpa_supplicant/Makefile
@@ -1706,9 +1706,11 @@ wpa_cli: $(OBJS_c)
LIBCTRL += ../src/common/wpa_ctrl.o
LIBCTRL += ../src/utils/os_$(CONFIG_OS).o
+LIBCTRL += ../src/utils/common.c
LIBCTRL += ../src/utils/wpa_debug.o
LIBCTRLSO += ../src/common/wpa_ctrl.c
LIBCTRLSO += ../src/utils/os_$(CONFIG_OS).c
+LIBCTRLSO += ../src/utils/common.c
LIBCTRLSO += ../src/utils/wpa_debug.c
libwpa_client.a: $(LIBCTRL)
--
2.6.2