0c15169f5a
Removed all patches, they are now included in this release. Added other patches fixing errors. Removed option BR2_PACKAGE_PPPD_RADIUS, upstream build system, now auto- conf-based, does not support disabling the radius plugin. Removed BR2_PACKAGE_PPPD_OVERWRITE_RESOLV_CONF, upstream now defaults to /etc, quoting README: "Note that if you have built and installed previous versions of this package and you want to continue having configuration and TDB files in /etc/ppp, you will need to use the --sysconfdir option to ./configure." Switched build system to autoconf, added optional systemd support. Added configure option to enable multilink support which now defaults to false but was enabled before: https://github.com/ppp-project/ppp/blob/2.4.9/pppd/Makefile.linux#L57 Signed-off-by: Bernd Kuhls <bernd@kuhls.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
45 lines
1.4 KiB
Diff
45 lines
1.4 KiB
Diff
From 9d6d326b2530cffb1414e4c401675117c42d43ce Mon Sep 17 00:00:00 2001
|
|
From: Eivind Naess <eivnaes@yahoo.com>
|
|
Date: Sun, 23 Apr 2023 11:30:43 -0700
|
|
Subject: [PATCH] Add configure check to see if we have struct sockaddr_ll
|
|
|
|
Fixes issue #411.
|
|
|
|
Signed-off-by: Eivind Naess <eivnaes@yahoo.com>
|
|
|
|
Upstream: https://github.com/ppp-project/ppp/commit/9d6d326b2530cffb1414e4c401675117c42d43ce
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
|
|
---
|
|
configure.ac | 3 ++-
|
|
pppd/plugins/pppoe/config.h.in | 2 ++
|
|
2 files changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 1180f64..38b24af 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -75,7 +75,8 @@ AM_COND_IF([LINUX], [
|
|
linux/if_ether.h \
|
|
linux/if_packet.h \
|
|
netinet/if_ether.h \
|
|
- netpacket/packet.h])])
|
|
+ netpacket/packet.h])
|
|
+ AC_CHECK_TYPES([struct sockaddr_ll], [], [], [#include <linux/if_packet.h>])])
|
|
|
|
AC_CHECK_SIZEOF(unsigned int)
|
|
AC_CHECK_SIZEOF(unsigned long)
|
|
diff --git a/pppd/plugins/pppoe/config.h.in b/pppd/plugins/pppoe/config.h.in
|
|
index d447f5e..d7d61c0 100644
|
|
--- a/pppd/plugins/pppoe/config.h.in
|
|
+++ b/pppd/plugins/pppoe/config.h.in
|
|
@@ -69,3 +69,5 @@
|
|
/* The size of `unsigned short', as computed by sizeof. */
|
|
#undef SIZEOF_UNSIGNED_SHORT
|
|
|
|
+/* Define to 1 if the system has the type `struct sockaddr_ll'. */
|
|
+#undef HAVE_STRUCT_SOCKADDR_LL
|
|
--
|
|
2.39.2
|
|
|