0d327c267a
This commit bumps the Python3 package to use Python 3.4.0rc1. About the patches: * The patches below 100 are significantly changed, because like for Python 2.x, a good number of improvements have been made in the upstream Python for cross-compilation. Therefore, almost all of these patches have been modified. * All the patches above 100 are simply updated for Python 3.4.0, with a small refactoring for the handling of test modules. The details of the python3.mk changes are: * --without-ensurepip to tell Python to not use PIP at build time. * Many environment variables are no longer passed, they were specific to our cross-compilation patches * The fixup of the LIBDIR in the Python Makefile is no longer needed since Python has switched to _sysconfigdata.py for distutils configuration instead of parsing the Makefile. * A new post patch hooks touches the two files generated by pgen to make sure they are newer than the pgen sources, which ensures pgen is not built/executed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
79 lines
2.7 KiB
Diff
79 lines
2.7 KiB
Diff
python3: Fix pyc-only related runtime exceptions
|
|
|
|
Python3 changes the pyc lookup strategy, ignoring the
|
|
__pycache__ directory if the .py file is missing. Change
|
|
install location to enable use of .pyc without their parent .py
|
|
|
|
See http://www.python.org/dev/peps/pep-3147
|
|
|
|
Signed-off-by: Daniel Nelson <daniel@sigpwr.com>
|
|
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -349,6 +349,23 @@
|
|
AC_SUBST(FRAMEWORKUNIXTOOLSPREFIX)
|
|
AC_SUBST(FRAMEWORKINSTALLAPPSPREFIX)
|
|
|
|
+STDLIB_CACHE_FLAGS=
|
|
+AC_MSG_CHECKING(for --enable-old-stdlib-cache)
|
|
+AC_ARG_ENABLE(old-stdlib-cache,
|
|
+ AS_HELP_STRING([--enable-old-stdlib-cache], [enable pre-pep3147 stdlib cache]),
|
|
+[
|
|
+ if test "$enableval" = "yes"
|
|
+ then
|
|
+ STDLIB_CACHE_FLAGS="-b"
|
|
+ else
|
|
+ STDLIB_CACHE_FLAGS=""
|
|
+ fi
|
|
+],
|
|
+[
|
|
+ STDLIB_CACHE_FLAGS=""
|
|
+])
|
|
+AC_SUBST(STDLIB_CACHE_FLAGS)
|
|
+
|
|
##AC_ARG_WITH(dyld,
|
|
## AS_HELP_STRING([--with-dyld],
|
|
## [Use (OpenStep|Rhapsody) dynamic linker]))
|
|
Index: b/Makefile.pre.in
|
|
===================================================================
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -157,6 +157,9 @@
|
|
# Options to enable prebinding (for fast startup prior to Mac OS X 10.3)
|
|
OTHER_LIBTOOL_OPT=@OTHER_LIBTOOL_OPT@
|
|
|
|
+# Option to enable old-style precompiled stdlib
|
|
+STDLIB_CACHE_FLAGS=@STDLIB_CACHE_FLAGS@
|
|
+
|
|
# Environment to run shared python without installed libraries
|
|
RUNSHARED= @RUNSHARED@
|
|
|
|
@@ -1231,21 +1234,21 @@
|
|
fi
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST) -f \
|
|
+ -d $(LIBDEST) -f $(STDLIB_CACHE_FLAGS) \
|
|
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
|
|
$(DESTDIR)$(LIBDEST)
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST) -f \
|
|
+ -d $(LIBDEST) -f $(STDLIB_CACHE_FLAGS) \
|
|
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
|
|
$(DESTDIR)$(LIBDEST)
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST)/site-packages -f \
|
|
+ -d $(LIBDEST)/site-packages -f $(STDLIB_CACHE_FLAGS) \
|
|
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST)/site-packages -f \
|
|
+ -d $(LIBDEST)/site-packages -f $(STDLIB_CACHE_FLAGS) \
|
|
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|