0d327c267a
This commit bumps the Python3 package to use Python 3.4.0rc1. About the patches: * The patches below 100 are significantly changed, because like for Python 2.x, a good number of improvements have been made in the upstream Python for cross-compilation. Therefore, almost all of these patches have been modified. * All the patches above 100 are simply updated for Python 3.4.0, with a small refactoring for the handling of test modules. The details of the python3.mk changes are: * --without-ensurepip to tell Python to not use PIP at build time. * Many environment variables are no longer passed, they were specific to our cross-compilation patches * The fixup of the LIBDIR in the Python Makefile is no longer needed since Python has switched to _sysconfigdata.py for distutils configuration instead of parsing the Makefile. * A new post patch hooks touches the two files generated by pgen to make sure they are newer than the pgen sources, which ensures pgen is not built/executed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
37 lines
1.8 KiB
Diff
37 lines
1.8 KiB
Diff
setup.py: do not add invalid header locations
|
|
|
|
This piece of code incorrectly adds /usr/include to
|
|
self.compiler.include_dirs, and results in the following invalid
|
|
compilation line:
|
|
|
|
/home/thomas/projets/buildroot/output/host/usr/bin/arm-none-linux-gnueabi-gcc
|
|
-fPIC -Wno-unused-result -Werror=declaration-after-statement -DNDEBUG -g
|
|
-O3 -Wall -Wstrict-prototypes -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
|
-D_FILE_OFFSET_BITS=64 -pipe -Os
|
|
-I./Include -I/usr/include -I. -IInclude
|
|
-I/home/thomas/projets/buildroot/output/host/usr/arm-buildroot-linux-gnueabi/sysroot/usr/include
|
|
-I/home/thomas/projets/buildroot/output/build/python3-3.4.0b1/Include
|
|
-I/home/thomas/projets/buildroot/output/build/python3-3.4.0b1
|
|
-c /home/thomas/projets/buildroot/output/build/python3-3.4.0b1/Modules/_struct.c
|
|
-o build/temp.linux-arm-3.4/home/thomas/projets/buildroot/output/build/python3-3.4.0b1/Modules/_struct.o
|
|
cc1: warning: include location "/usr/include" is unsafe for cross-compilation [-Wpoison-system-directories]
|
|
|
|
The -I/usr/include is wrong when cross compiling, so we disable adding
|
|
INCLUDEDIR and LIBDIR from the host when cross compiling.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Index: b/setup.py
|
|
===================================================================
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -487,7 +487,8 @@
|
|
add_dir_to_list(dir_list, directory)
|
|
|
|
if os.path.normpath(sys.base_prefix) != '/usr' \
|
|
- and not sysconfig.get_config_var('PYTHONFRAMEWORK'):
|
|
+ and not sysconfig.get_config_var('PYTHONFRAMEWORK') \
|
|
+ and not cross_compiling:
|
|
# OSX note: Don't add LIBDIR and INCLUDEDIR to building a framework
|
|
# (PYTHONFRAMEWORK is set) to avoid # linking problems when
|
|
# building a framework with different architectures than
|