29a254bdb1
Enable support for mysql and pgsql. Patches sent upstream (pull request on github). Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
54 lines
1.8 KiB
Diff
54 lines
1.8 KiB
Diff
From b095b56b7cf96a5b1a5e411b6da14b5e9f237a43 Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Wed, 14 Jan 2015 10:07:50 -0300
|
|
Subject: [PATCH] configure.ac: make mysql support cross-compile friendly
|
|
|
|
When cross-compiling mysql_config shouldn't be expected to be in PATH
|
|
since normally this would point to distribution mysql rather than cross,
|
|
which can be of a totally different architecture.
|
|
|
|
Change it so we can use ac_cv_prog_MYSQL_CONFIG to point to the real one.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
---
|
|
configure.ac | 15 ++++++++-------
|
|
1 file changed, 8 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index ad7274c..4e662dc 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -547,21 +547,22 @@ AC_ARG_ENABLE(mysql,
|
|
)
|
|
if test "x$enable_mysql" = "xyes"; then
|
|
AC_CHECK_PROG(
|
|
- [HAVE_MYSQL_CONFIG],
|
|
+ [MYSQL_CONFIG],
|
|
[mysql_config],
|
|
- [yes],,,
|
|
+ [mysql_config],
|
|
+ [no],,
|
|
)
|
|
- if test "x${HAVE_MYSQL_CONFIG}" != "xyes"; then
|
|
- AC_MSG_FAILURE([mysql_config not found in PATH - usually a package named mysql-dev, libmysql-dev or similar, is missing - install it to fix this issue])
|
|
+ if test "x${MYSQL_CONFIG}" = "xno"; then
|
|
+ AC_MSG_FAILURE([mysql_config not found - usually a package named mysql-dev, libmysql-dev or similar, is missing - install it to fix this issue])
|
|
fi
|
|
AC_CHECK_LIB(
|
|
[mysqlclient],
|
|
[mysql_init],
|
|
- [MYSQL_CFLAGS=`mysql_config --cflags`
|
|
- MYSQL_LIBS=`mysql_config --libs`
|
|
+ [MYSQL_CFLAGS=`$MYSQL_CONFIG --cflags`
|
|
+ MYSQL_LIBS=`$MYSQL_CONFIG --libs`
|
|
],
|
|
[AC_MSG_FAILURE([MySQL library is missing])],
|
|
- [`mysql_config --libs`]
|
|
+ [`$MYSQL_CONFIG --libs`]
|
|
)
|
|
AC_MSG_CHECKING(if we have mysql_library_init)
|
|
save_CFLAGS="$CFLAGS"
|
|
--
|
|
2.0.5
|
|
|