2a56de2dec
parted uses libiconv but doesn't link with it. All the checks are there in configure, but the Makefile.am doesn't add it to the link. Add a patch to fix this. Also add an optional dependency on libiconv, so it is reproducible. While we're at it, regenerate the existing patches on top of v3.2, and make patch 0003 a properly git formatted one. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Cc: srg.venema@gmail.com Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
28 lines
801 B
Diff
28 lines
801 B
Diff
From 2078c07d38ee7841b89ac8d81afc5e8bfcd4f703 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Sun, 8 Oct 2017 00:58:58 +0200
|
|
Subject: [PATCH] Include <fcntl.h> to get loff_t definition
|
|
|
|
Patch borrowed from Alpine Linux at
|
|
http://git.alpinelinux.org/cgit/aports/plain/main/parted/fix-includes.patch. Solves
|
|
build with musl.
|
|
---
|
|
libparted/fs/xfs/platform_defs.h | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/libparted/fs/xfs/platform_defs.h b/libparted/fs/xfs/platform_defs.h
|
|
index 2b55752..17023dc 100644
|
|
--- a/libparted/fs/xfs/platform_defs.h
|
|
+++ b/libparted/fs/xfs/platform_defs.h
|
|
@@ -35,6 +35,7 @@
|
|
#define __XFS_PLATFORM_DEFS_H__
|
|
|
|
#include <stdio.h>
|
|
+#include <fcntl.h>
|
|
#include <stdarg.h>
|
|
#include <assert.h>
|
|
#include <endian.h>
|
|
--
|
|
2.14.2
|
|
|