8fa35b77f7
Following patches are required for successful bulding of uClibc built-int tests (BR2_UCLIBC_INSTALL_TEST_SUITE=y): 1. uclibc-0059-test-cater-for-config.patch http://git.uclibc.org/uClibc/commit/test?id=7598eeaa1defa2884adaa890bb115c493d69cc35 2. uclibc-0058-test-tls-fix-build-with-newer-binutils.patch http://git.uclibc.org/uClibc/commit/test?id=931e8391565323ed2e589c83b83a7345813a5514 3. uclibc-0060-test-Fix-math-c-dependency.patch http://git.uclibc.org/uClibc/commit/test/math?id=a20a91ad7c042c46e4a2adee6d03315f857f9985 All mentioned patches must be removed as obsolete on bumping uClibc to the next release. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Anton Kolesov <akolesov@synopsys.com> Cc: Peter Korsgaard <peter@korsgaard.com> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
38 lines
1.4 KiB
Diff
38 lines
1.4 KiB
Diff
From 931e8391565323ed2e589c83b83a7345813a5514 Mon Sep 17 00:00:00 2001
|
|
From: Baruch Siach <baruch@tkos.co.il>
|
|
Date: Wed, 02 Oct 2013 07:08:29 +0000
|
|
Subject: test: tls: fix build with newer binutils
|
|
|
|
Fix the following build failures:
|
|
|
|
ld: tst-tls10.o: undefined reference to symbol 'f2a'
|
|
ld: tst-tls12.o: undefined reference to symbol 'a1'
|
|
|
|
binutils ld defaults to --no-copy-dt-needed-entries since version 2.22. Add
|
|
library dependencies explicitly.
|
|
|
|
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
|
|
---
|
|
(limited to 'test')
|
|
|
|
diff --git a/test/tls/Makefile.in b/test/tls/Makefile.in
|
|
index 875c607..7ab4e2a 100644
|
|
--- a/test/tls/Makefile.in
|
|
+++ b/test/tls/Makefile.in
|
|
@@ -102,9 +102,9 @@ LDFLAGS_tst-tls6 := -ldl
|
|
LDFLAGS_tst-tls7 := -ldl
|
|
LDFLAGS_tst-tls8 := -ldl
|
|
LDFLAGS_tst-tls9 := -ldl
|
|
-LDFLAGS_tst-tls10 := -Wl,-rpath-link=. tst-tlsmod8.so
|
|
-LDFLAGS_tst-tls11 := -Wl,-rpath-link=. tst-tlsmod10.so
|
|
-LDFLAGS_tst-tls12 := -Wl,-rpath-link=. tst-tlsmod12.so
|
|
+LDFLAGS_tst-tls10 := -Wl,-rpath-link=. tst-tlsmod8.so tst-tlsmod7.so
|
|
+LDFLAGS_tst-tls11 := -Wl,-rpath-link=. tst-tlsmod9.so tst-tlsmod10.so
|
|
+LDFLAGS_tst-tls12 := -Wl,-rpath-link=. tst-tlsmod11.so tst-tlsmod12.so
|
|
LDFLAGS_tst-tls13 := -ldl -Wl,-rpath-link=.
|
|
LDFLAGS_tst-tls14 := -ldl -Wl,-rpath-link=. tst-tlsmod14a.so
|
|
LDFLAGS_tst-tls15 := -ldl -Wl,-rpath-link=.
|
|
--
|
|
cgit v0.9.1
|