ecb26b1add
[Thomas: - Remove dependency on python (already a dependency of python-sip), and add a dependency on host-python-sip, since python-sip no longer depends on host-python-sip. - Make the code Python 2 / Python 3 compatible (both have been tested). - Fix indentation all over the place. - Remove double quotes when defining variable values, not needed. - Add <pkg>_BUILD_CMDS to do the build process separately from the installation. - Create a PYTHON_PYQT_CONF_OPTS variable with all the config options, since some of them are now conditional. - Use 'compileall' to byte-compile the dummy __init__.py.] Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com> Cc: Sergey Kostanbaev <sergey.kostanbaev@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
30 lines
1.2 KiB
Diff
30 lines
1.2 KiB
Diff
Do not run qtdetail
|
|
|
|
qtdetail is a tool that generates qtdetail.out. Since this program is
|
|
cross-compiled, it's not possible to run it on the host.
|
|
|
|
Consequently, python-pyqt.mk generates the qtdetail.out file before
|
|
calling configure-ng.py.
|
|
|
|
Therefore, this patch makes sure that the pre-generated qtdetail.out
|
|
file is kept, and that qtdetail is not executed.
|
|
|
|
Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
|
|
Signed-off-by: Sergey Kostanbaev <sergey.kostanbaev@gmail.com>
|
|
---
|
|
Index: PyQt-x11-gpl-4.11.3/configure-ng.py
|
|
===================================================================
|
|
--- PyQt-x11-gpl-4.11.3.orig/configure-ng.py
|
|
+++ PyQt-x11-gpl-4.11.3/configure-ng.py
|
|
@@ -672,10 +672,6 @@ int main(int argc, char **argv)
|
|
if cmd is None:
|
|
error("Failed to determine the detail of your Qt installation. Try again using the --verbose flag to see more detail about the problem.")
|
|
|
|
- # Create the output file, first making sure it doesn't exist.
|
|
- remove_file(out_file)
|
|
- run_command(cmd, verbose)
|
|
-
|
|
if not os.access(out_file, os.F_OK):
|
|
error("%s failed to create %s. Make sure your Qt installation is correct." % (cmd, out_file))
|
|
|