e84a286762
Currently, we're packaging FreeRDP from the stable-1.1 branch, which has not evolved since march 2015 and hasn't seen any release (not even a tag) since July 2013. It is by all purpose and means, dead. Other packages that may use FreeRDP (like weston) are now migrating to, or have already migrated to using the API from master, which has changed a bit from what was available on the stable-1.1 branch. So, those packages now FTBFS. However, FreeRDP still has not done a release from their master branch; the last tag dates back to September 2014 and there are 1850+ changes on top of that tag. So, switch to using the currently-latest commit from master. This version can also use gstreamer-1.x (in addition to gst-0.x), which needs quite some rework on how we handle the dependency on gstreamer. Drop gstreamer support entirely, support for gst-0.x and gst-1.x will be re-added in a followup patch. Similarly, a wayland client can now be built, support for which will be added in a subsequent path; it is currently forcibly disabled. The way the libraries are built has changed: the previous single library has been split in multiple libraries, each implementing parts of the RDP protocol. Slight rewording of the prompts: - drop the 'install' for client and server. - drop 'freerdp' from the client and server comment The location of the server keys has changed, so copy them from the new location. Finally, drop patches 1 and 3, applied upstrem; rename remaining patches. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
27 lines
1.2 KiB
Diff
27 lines
1.2 KiB
Diff
winpr/tools: fix building shared libs
|
|
|
|
libwinpr-makecert-tool.a is used to build libxfreerdp-server.so, so even
|
|
if we are building a static libwinpr-makecert-tool.a library, we need to
|
|
build it with -fPIC.
|
|
|
|
Patch and commit log suggested by Samuel MARTIN.
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
Cc: Samuel Martin <s.martin49@gmail.com>
|
|
|
|
diff -durN freerdp-440916eae2e07463912d5fe507677e67096eb083.orig/winpr/tools/makecert/CMakeLists.txt freerdp-440916eae2e07463912d5fe507677e67096eb083/winpr/tools/makecert/CMakeLists.txt
|
|
--- freerdp-440916eae2e07463912d5fe507677e67096eb083.orig/winpr/tools/makecert/CMakeLists.txt 2014-08-25 06:52:43.000000000 -0700
|
|
+++ freerdp-440916eae2e07463912d5fe507677e67096eb083/winpr/tools/makecert/CMakeLists.txt 2014-10-24 15:39:39.600319523 -0700
|
|
@@ -37,4 +37,11 @@
|
|
add_subdirectory(cli)
|
|
|
|
set_property(TARGET ${MODULE_NAME} PROPERTY FOLDER "WinPR/Tools")
|
|
+
|
|
+if(BUILD_SHARED_LIBS)
|
|
+ # build libwinpr-makecert-tool.a with PIC because it is used to build
|
|
+ # the shared library libxfreerdp-server.so.
|
|
+ set_property(TARGET ${MODULE_NAME} PROPERTY POSITION_INDEPENDENT_CODE TRUE)
|
|
+endif()
|
|
+
|
|
export_complex_library(LIBNAME ${MODULE_NAME})
|