3e5926555b
Patch 0005 tweaked to apply on this release. Patch 0006 already included in this release: https://cgit.freedesktop.org/mesa/mesa/commit/?id=e75001811e3b66986b4ede165a0fdde703d4f05b zlib is now a mandatory dependency. https://cgit.freedesktop.org/mesa/mesa/commit/?h=17.1&id=85a9b1b562b6a73b9494b3fad25172da3dc90fc2 [Bernd: added in v2] - bump to mesa3d version 17.1.2 - squashed mesa3d-headers bump for bisectability - renumbered patch 0007 - added zlib link in patch message - Vulkan Intel driver does not depend on the i965 dri driver anymore https://cgit.freedesktop.org/mesa/mesa/commit/configure.ac?h=17.1&id=9aebdb5d082ec640fe8a14704201952bddb50a88 - Gallium vc4 driver depends on NEON support https://cgit.freedesktop.org/mesa/mesa/commit/?h=17.1&id=4d30024238efa829cabc72c1601beeee18c3dbf2 Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
43 lines
1.4 KiB
Diff
43 lines
1.4 KiB
Diff
From 60ee5191a0c074251862a15b12afdc9db0b2df38 Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Thu, 17 Nov 2016 15:36:54 -0300
|
|
Subject: [PATCH] configure.ac: invert order for wayland-scanner check
|
|
|
|
When cross-compiling the .pc file might point to the wrong
|
|
wayland-scanner binary (target rather than host) resulting in a
|
|
non-executable and wrong scanner.
|
|
Try searching the PATH first, and if that fails fall back into
|
|
pkg-config.
|
|
|
|
[Vincent: tweak patch for 17.1.1 version]
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
---
|
|
configure.ac | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 2c7e636..0198d52 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -2174,11 +2174,11 @@ if test "x$with_platforms" != xauto; then
|
|
with_egl_platforms=$with_platforms
|
|
fi
|
|
|
|
-PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
|
|
- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
|
|
- WAYLAND_SCANNER='')
|
|
+AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
|
|
if test "x$WAYLAND_SCANNER" = x; then
|
|
- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
|
|
+ PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
|
|
+ WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
|
|
+ WAYLAND_SCANNER='')
|
|
fi
|
|
|
|
# Do per-EGL platform setups and checks
|
|
--
|
|
2.7.3
|
|
|