a570dea84f
Tested with Qemu 2.0.0. Overlay is from https://github.com/jcmvbkbc/xtensa-toolchain-build/tree/master/overlays Many thanks to Max Filippov <jcmvbkbc@gmail.com> for his extended help and kernel config examples. A small kernel patch is required, because mkimage does not contain support for Xtensa and the uImage target is failing. Redboot is unused so disable it, too. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
17 lines
689 B
Diff
17 lines
689 B
Diff
disable boot-uboot and boot-redboot, requires a patched u-boot and mkimage
|
|
|
|
Signed-off-by:Waldemar Brodkorb <wbx@openadk.org>
|
|
|
|
diff -Nur linux-3.15.orig/arch/xtensa/boot/Makefile linux-3.15/arch/xtensa/boot/Makefile
|
|
--- linux-3.15.orig/arch/xtensa/boot/Makefile 2014-06-08 20:19:54.000000000 +0200
|
|
+++ linux-3.15/arch/xtensa/boot/Makefile 2014-06-14 20:07:15.206091165 +0200
|
|
@@ -23,7 +23,7 @@
|
|
|
|
bootdir-$(CONFIG_XTENSA_PLATFORM_ISS) += boot-elf
|
|
bootdir-$(CONFIG_XTENSA_PLATFORM_XT2000) += boot-redboot boot-elf boot-uboot
|
|
-bootdir-$(CONFIG_XTENSA_PLATFORM_XTFPGA) += boot-redboot boot-elf boot-uboot
|
|
+bootdir-$(CONFIG_XTENSA_PLATFORM_XTFPGA) += boot-elf
|
|
|
|
zImage Image: $(bootdir-y)
|
|
|