fbf7d55421
This bump will fix the following build failure raised since bump of wayland to version 1.20.0 in commitf94ba5c31c
thanks to71d46212a9
and2c33597245
: /home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/powerpc64-buildroot-linux-gnu/9.3.0/../../../../powerpc64-buildroot-linux-gnu/bin/ld: ../../lib/libwaffle-1.so.0.6.1: undefined reference to `wl_proxy_get_version' /home/giuliobenetti/autobuild/run/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/powerpc64-buildroot-linux-gnu/9.3.0/../../../../powerpc64-buildroot-linux-gnu/bin/ld: ../../lib/libwaffle-1.so.0.6.1: undefined reference to `wl_proxy_marshal_flags' https://gitlab.freedesktop.org/mesa/waffle/-/tags/v1.7.0 https://gitlab.freedesktop.org/mesa/waffle/-/tags/v1.6.3 https://gitlab.freedesktop.org/mesa/waffle/-/tags/v1.6.2 Fixes: - http://autobuild.buildroot.org/results/1fb1540b0ae6037140f386f44d6e17735f0674c4 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
43 lines
1.2 KiB
Diff
43 lines
1.2 KiB
Diff
From 8b0ae49c8bea78df73c3ecae0059d54a95c561fa Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@gmail.com>
|
|
Date: Sun, 24 Dec 2017 00:11:45 +0100
|
|
Subject: [PATCH] cmake: forward cflags from *.pc files to waffle cflags
|
|
|
|
When building mesa egl without x11 and gles2 the headers need a
|
|
EGL_NO_X11 define to avoid including X11 headers.
|
|
|
|
This define EGL_NO_X11 is lost while building waffle
|
|
since CFLAGS defined by pc files are not used.
|
|
|
|
EGL_NO_X11 is defined in CFLAGS from egl.pc.
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
[Upstream status:
|
|
https://gitlab.freedesktop.org/mesa/waffle/-/merge_requests/111]
|
|
---
|
|
src/waffle/CMakeLists.txt | 8 ++++++++
|
|
1 file changed, 8 insertions(+)
|
|
|
|
diff --git a/src/waffle/CMakeLists.txt b/src/waffle/CMakeLists.txt
|
|
index d76e029..2ff72c8 100644
|
|
--- a/src/waffle/CMakeLists.txt
|
|
+++ b/src/waffle/CMakeLists.txt
|
|
@@ -5,6 +5,14 @@
|
|
add_definitions(
|
|
-DWAFFLE_API_VERSION=${waffle_api_version}
|
|
-DWAFFLE_API_EXPERIMENTAL
|
|
+ ${egl_CFLAGS}
|
|
+ ${gbm_CFLAGS}
|
|
+ ${gl_CFLAGS}
|
|
+ ${GLEXT_CFLAGS}
|
|
+ ${libudev_CFLAGS}
|
|
+ ${wayland-client_CFLAGS}
|
|
+ ${wayland-egl_CFLAGS}
|
|
+ ${x11-xcb_CFLAGS}
|
|
)
|
|
|
|
include_directories(
|
|
--
|
|
2.14.3
|
|
|