0adc0e24ee
[Thomas: - fix commit title - powertop wants libintl unconditionally, so make sure BR2_PACKAGE_GETTEXT is selected when BR2_NEEDS_GETTEXT is set, and add gettext to the dependencies. - add missing comment about thread dependency. - add missing dependency on host-pkgconf, without which powertop cannot find libnl. - patch src/Makefile.am to not pass -fstack-protector, which fails to build if the toolchain does not have SSP support. - rename patch powertop-autotune.patch to confirm to the patch naming convention.] Signed-off-by: Steven Noonan <steven@uplinklabs.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
16 lines
493 B
Diff
16 lines
493 B
Diff
Patch pulled from https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/powertop&id=37469c47b885c50365f57044e4ad72e0e3512b91
|
|
|
|
Fixes a use-after-close bug in create_all_devfreq_devices().
|
|
|
|
Signed-off-by: Steven Noonan <steven@uplinklabs.net>
|
|
|
|
--- a/src/devices/devfreq.cpp
|
|
+++ b/src/devices/devfreq.cpp
|
|
@@ -247,6 +247,7 @@ void create_all_devfreq_devices(void)
|
|
fprintf(stderr, "Devfreq not enabled\n");
|
|
is_enabled = false;
|
|
closedir(dir);
|
|
+ dir = NULL;
|
|
return;
|
|
}
|