4959dabe7d
Convert patches from pure configure ones to *.m4/configure.in cleanness. This allows us to AUTORECONF (well, not quite, but close). Even though upstream will probably not accept them it's the right way. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
56 lines
2.0 KiB
Diff
56 lines
2.0 KiB
Diff
Tweak PHP_SETUP_ICONV from aclocal/acinclude.m4 to not
|
|
PHP_ADD_INCLUDE $ICONV_DIR/include since the tests use
|
|
test instead of AC_TRY_LINK to find headers which is bad,
|
|
specially when adding /usr and /usr/local to the mix.
|
|
Do basically the same with ext/iconv/config.m4 by tweaking
|
|
PHP_ICONV_H_PATH which, again, uses test and absolute paths.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
[Gustavo: convert to nice m4 instead of patching configure]
|
|
|
|
diff -Nura php-5.6.7.orig/aclocal.m4 php-5.6.7/aclocal.m4
|
|
--- php-5.6.7.orig/aclocal.m4 2015-04-08 11:08:11.208848359 -0300
|
|
+++ php-5.6.7/aclocal.m4 2015-04-08 11:42:17.321044950 -0300
|
|
@@ -2474,7 +2474,7 @@
|
|
dnl
|
|
if test "$found_iconv" = "no"; then
|
|
|
|
- for i in $PHP_ICONV /usr/local /usr; do
|
|
+ for i in $PHP_ICONV; do
|
|
if test -r $i/include/giconv.h; then
|
|
AC_DEFINE(HAVE_GICONV_H, 1, [ ])
|
|
ICONV_DIR=$i
|
|
diff -Nura php-5.6.7.orig/ext/iconv/config.m4 php-5.6.7/ext/iconv/config.m4
|
|
--- php-5.6.7.orig/ext/iconv/config.m4 2015-04-08 11:08:11.184847544 -0300
|
|
+++ php-5.6.7/ext/iconv/config.m4 2015-04-08 11:39:07.823608030 -0300
|
|
@@ -14,28 +14,8 @@
|
|
])
|
|
|
|
if test "$iconv_avail" != "no"; then
|
|
- if test -z "$ICONV_DIR"; then
|
|
- for i in /usr/local /usr; do
|
|
- if test -f "$i/include/iconv.h" || test -f "$i/include/giconv.h"; then
|
|
- PHP_ICONV_PREFIX="$i"
|
|
- break
|
|
- fi
|
|
- done
|
|
- if test -z "$PHP_ICONV_PREFIX"; then
|
|
- PHP_ICONV_PREFIX="/usr"
|
|
- fi
|
|
- else
|
|
- PHP_ICONV_PREFIX="$ICONV_DIR"
|
|
- fi
|
|
|
|
- CFLAGS="-I$PHP_ICONV_PREFIX/include $CFLAGS"
|
|
- LDFLAGS="-L$PHP_ICONV_PREFIX/$PHP_LIBDIR $LDFLAGS"
|
|
-
|
|
- if test -r "$PHP_ICONV_PREFIX/include/giconv.h"; then
|
|
- PHP_ICONV_H_PATH="$PHP_ICONV_PREFIX/include/giconv.h"
|
|
- else
|
|
- PHP_ICONV_H_PATH="$PHP_ICONV_PREFIX/include/iconv.h"
|
|
- fi
|
|
+ PHP_ICONV_H_PATH="iconv.h"
|
|
|
|
AC_MSG_CHECKING([if iconv is glibc's])
|
|
AC_TRY_LINK([#include <gnu/libc-version.h>],[gnu_get_libc_version();],
|