8290f2ea11
[Thomas: - Adjust the comment about the dependency on erlang - Fix license to be 'GPLv2+ with OpenSSL exception' and not just 'GPLv2+' - Use double quotes instead of simple quotes in the .mk file. - Don't use the EJABBERD_MAKE_ENV variable, since it's not defined anywhere. - Remove the 0007-fix-init.patch patch, since we're not using the init script provided by ejabberd, and rename 0008-fix-install-permissions.patch to 0007-fix-install-permissions.patch.] Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
27 lines
968 B
Diff
27 lines
968 B
Diff
Description: remove installing documentation
|
|
Without this patch, the Makefile will try to install ejabberd
|
|
documentation even if it is not generated, which will fail.
|
|
Author: Johan Oudinet <johan.oudinet@gmail.com>
|
|
|
|
Index: ejabberd/Makefile.in
|
|
===================================================================
|
|
--- ejabberd.orig/Makefile.in 2014-10-21 16:43:42.604972005 +0200
|
|
+++ ejabberd/Makefile.in 2014-10-21 16:45:12.419989667 +0200
|
|
@@ -156,16 +156,6 @@ install: all
|
|
$(INSTALL) -d -m 750 $(O_USER) $(LOGDIR)
|
|
$(CHOWN_COMMAND) -R @INSTALLUSER@ $(LOGDIR) >$(CHOWN_OUTPUT)
|
|
chmod -R 750 $(LOGDIR)
|
|
- #
|
|
- # Documentation
|
|
- $(INSTALL) -d $(DOCDIR)
|
|
- $(INSTALL) -m 644 doc/dev.html $(DOCDIR)
|
|
- $(INSTALL) -m 644 doc/guide.html $(DOCDIR)
|
|
- $(INSTALL) -m 644 doc/*.png $(DOCDIR)
|
|
- [ -f doc/guide.pdf ] \
|
|
- && $(INSTALL) -m 644 doc/guide.pdf $(DOCDIR) \
|
|
- || echo "No doc/guide.pdf was built"
|
|
- $(INSTALL) -m 644 COPYING $(DOCDIR)
|
|
|
|
uninstall: uninstall-binary
|
|
|