8290f2ea11
[Thomas: - Adjust the comment about the dependency on erlang - Fix license to be 'GPLv2+ with OpenSSL exception' and not just 'GPLv2+' - Use double quotes instead of simple quotes in the .mk file. - Don't use the EJABBERD_MAKE_ENV variable, since it's not defined anywhere. - Remove the 0007-fix-init.patch patch, since we're not using the init script provided by ejabberd, and rename 0008-fix-install-permissions.patch to 0007-fix-install-permissions.patch.] Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
46 lines
1.4 KiB
Diff
46 lines
1.4 KiB
Diff
Description: correct include
|
|
This part of the code was moved into it's own project and was packaged
|
|
separately by me. To make the build process work, this small fix is
|
|
necessary.
|
|
Author: Philipp Huebner <debalance@debian.org>
|
|
|
|
Index: ejabberd/src/mod_sip_proxy.erl
|
|
===================================================================
|
|
--- ejabberd.orig/src/mod_sip_proxy.erl
|
|
+++ ejabberd/src/mod_sip_proxy.erl
|
|
@@ -21,7 +21,7 @@
|
|
|
|
-include("ejabberd.hrl").
|
|
-include("logger.hrl").
|
|
--include_lib("esip/include/esip.hrl").
|
|
+-include_lib("p1_sip/include/esip.hrl").
|
|
|
|
-define(SIGN_LIFETIME, 300). %% in seconds.
|
|
|
|
Index: ejabberd/src/mod_sip.erl
|
|
===================================================================
|
|
--- ejabberd.orig/src/mod_sip.erl
|
|
+++ ejabberd/src/mod_sip.erl
|
|
@@ -20,7 +20,7 @@
|
|
|
|
-include("ejabberd.hrl").
|
|
-include("logger.hrl").
|
|
--include_lib("esip/include/esip.hrl").
|
|
+-include_lib("p1_sip/include/esip.hrl").
|
|
|
|
%%%===================================================================
|
|
%%% API
|
|
Index: ejabberd/src/mod_sip_registrar.erl
|
|
===================================================================
|
|
--- ejabberd.orig/src/mod_sip_registrar.erl
|
|
+++ ejabberd/src/mod_sip_registrar.erl
|
|
@@ -20,7 +20,7 @@
|
|
|
|
-include("ejabberd.hrl").
|
|
-include("logger.hrl").
|
|
--include_lib("esip/include/esip.hrl").
|
|
+-include_lib("p1_sip/include/esip.hrl").
|
|
|
|
-define(CALL_TIMEOUT, timer:seconds(30)).
|
|
-define(DEFAULT_EXPIRES, 3600).
|