f9dc4bab9f
Drop local patches since they have been upstreamed but add a new local patch already upstreamed that checks for libevent and sqlite since with the adding of reexport they became mandatory. This is because it's not possible to disable reexport. Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com> Reviewed-by: Petr Vorel <petr.vorel@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
80 lines
2.2 KiB
Diff
80 lines
2.2 KiB
Diff
From bc4a5deef9f820c55fdac3c0070364c17cd91cca Mon Sep 17 00:00:00 2001
|
|
From: Wiktor Jaskulski <wjaskulski@adva.com>
|
|
Date: Thu, 11 May 2023 15:28:23 -0400
|
|
Subject: [PATCH] configure.ac: libevent and libsqlite3 checked when nfsv4 is
|
|
disabled
|
|
|
|
Upstream: https://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commit;h=bc4a5deef9f820c55fdac3c0070364c17cd91cca
|
|
|
|
Signed-off-by: Steve Dickson <steved@redhat.com>
|
|
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
|
---
|
|
configure.ac | 38 +++++++++++++++-----------------------
|
|
1 file changed, 15 insertions(+), 23 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 9df52e9c..6fbcb974 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -338,42 +338,34 @@ CPPFLAGS="${nfsutils_save_CPPFLAGS}"
|
|
AC_CHECK_HEADER(uuid/uuid.h, ,
|
|
AC_MSG_ERROR([Cannot find needed header file uuid/uuid.h. Install libuuid-devel]))
|
|
|
|
+dnl check for libevent libraries and headers
|
|
+AC_LIBEVENT
|
|
+
|
|
+dnl Check for sqlite3
|
|
+AC_SQLITE3_VERS
|
|
+
|
|
+case $libsqlite3_cv_is_recent in
|
|
+yes) ;;
|
|
+unknown)
|
|
+ dnl do not fail when cross-compiling
|
|
+ AC_MSG_WARN([assuming sqlite is at least v3.3]) ;;
|
|
+*)
|
|
+ AC_MSG_ERROR([nfsdcld requires sqlite-devel]) ;;
|
|
+esac
|
|
+
|
|
if test "$enable_nfsv4" = yes; then
|
|
- dnl check for libevent libraries and headers
|
|
- AC_LIBEVENT
|
|
|
|
dnl check for the keyutils libraries and headers
|
|
AC_KEYUTILS
|
|
|
|
- dnl Check for sqlite3
|
|
- AC_SQLITE3_VERS
|
|
-
|
|
if test "$enable_nfsdcld" = "yes"; then
|
|
AC_CHECK_HEADERS([libgen.h sys/inotify.h], ,
|
|
AC_MSG_ERROR([Cannot find header needed for nfsdcld]))
|
|
-
|
|
- case $libsqlite3_cv_is_recent in
|
|
- yes) ;;
|
|
- unknown)
|
|
- dnl do not fail when cross-compiling
|
|
- AC_MSG_WARN([assuming sqlite is at least v3.3]) ;;
|
|
- *)
|
|
- AC_MSG_ERROR([nfsdcld requires sqlite-devel]) ;;
|
|
- esac
|
|
fi
|
|
|
|
if test "$enable_nfsdcltrack" = "yes"; then
|
|
AC_CHECK_HEADERS([libgen.h sys/inotify.h], ,
|
|
AC_MSG_ERROR([Cannot find header needed for nfsdcltrack]))
|
|
-
|
|
- case $libsqlite3_cv_is_recent in
|
|
- yes) ;;
|
|
- unknown)
|
|
- dnl do not fail when cross-compiling
|
|
- AC_MSG_WARN([assuming sqlite is at least v3.3]) ;;
|
|
- *)
|
|
- AC_MSG_ERROR([nfsdcltrack requires sqlite-devel]) ;;
|
|
- esac
|
|
fi
|
|
|
|
else
|
|
--
|
|
2.34.1
|
|
|