kumquat-buildroot/package/iptables/0002-iptables-add-xtables-config-parser.h-to-BUILT_SOURCES.patch
Gustavo Zacarias 5d4df62204 iptables: add parallel build fix patch
Fixes:
http://autobuild.buildroot.net/results/5c4/5c4ca595c4bf744aa00fc58851eeccf81f9c6ecc/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-12-30 19:22:56 +01:00

40 lines
1.4 KiB
Diff

From 4dc8e2aa91bd4151f7e5cd56d88d3731b4c1525e Mon Sep 17 00:00:00 2001
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
Date: Wed, 30 Dec 2015 14:39:35 -0300
Subject: [PATCH] iptables: add xtables-config-parser.h to BUILT_SOURCES
Otherwise other sources that use it might be built before it's ready leading
to build failure, for example by iptables/nft.c
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
---
Status: sent upstream (mailing list, no link yet)
iptables/Makefile.am | 3 +++
1 file changed, 3 insertions(+)
diff --git a/iptables/Makefile.am b/iptables/Makefile.am
index 3c0faa5..c3eb8a8 100644
--- a/iptables/Makefile.am
+++ b/iptables/Makefile.am
@@ -4,6 +4,8 @@ AM_CFLAGS = ${regular_CFLAGS}
AM_CPPFLAGS = ${regular_CPPFLAGS} -I${top_builddir}/include -I${top_srcdir}/include ${kinclude_CPPFLAGS} ${libmnl_CFLAGS} ${libnftnl_CFLAGS} ${libnetfilter_conntrack_CFLAGS}
AM_YFLAGS = -d
+BUILT_SOURCES =
+
xtables_multi_SOURCES = xtables-multi.c iptables-xml.c
xtables_multi_CFLAGS = ${AM_CFLAGS}
xtables_multi_LDADD = ../extensions/libext.a
@@ -27,6 +29,7 @@ xtables_multi_LDADD += ../libxtables/libxtables.la -lm
# nftables compatibility layer
if ENABLE_NFTABLES
+BUILT_SOURCES += xtables-config-parser.h
xtables_compat_multi_SOURCES = xtables-compat-multi.c iptables-xml.c
xtables_compat_multi_CFLAGS = ${AM_CFLAGS}
xtables_compat_multi_LDADD = ../extensions/libext.a ../extensions/libext_ebt.a
--
2.4.10