214fe53106
Let's bump at to version 3.2.2 by: - moving SITE to http://software.calhariz.com/at that is the official at realease site while the actual(https://salsa.debian.org/debian/at) doesn't provide consitent tarballs. - rebasing 2 local patches(some some of them has not been accepted upstream because of removing -g root -o root while installing, while other simply has not been taken into account for 1 year. Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
114 lines
5.7 KiB
Diff
114 lines
5.7 KiB
Diff
From cbfd3296d7d0742d9e35b01ec9e433afe2c36c63 Mon Sep 17 00:00:00 2001
|
|
From: Marc Kleine-Budde <mkl@pengutronix.de>
|
|
Date: Tue, 1 Dec 2009 20:57:45 +0100
|
|
Subject: [PATCH] Makefile.in: replace IROOT by DESTDIR
|
|
|
|
This patch replaces IROOT by DESTDIR, which is the autotools standard
|
|
variable. For backwards compatibilty IROOT overwrites the DESTDIR.
|
|
|
|
Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
[Vincent: tweak the patch for the new version]
|
|
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
|
[Giulio: convert patch to git format and rebase to version 3.2.2]
|
|
---
|
|
Makefile.in | 72 ++++++++++++++++++++++++++++-------------------------
|
|
1 file changed, 38 insertions(+), 34 deletions(-)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 3e8303c..a7197f2 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -20,6 +20,10 @@ etcdir = @ETCDIR@
|
|
atjobdir = @ATJBD@
|
|
systemdsystemunitdir = @systemdsystemunitdir@
|
|
|
|
+ifdef IROOT
|
|
+DESTDIR = $(DESTDIR)
|
|
+endif
|
|
+
|
|
DAEMON_USERNAME = @DAEMON_USERNAME@
|
|
DAEMON_GROUPNAME= @DAEMON_GROUPNAME@
|
|
LOADAVG_MX = @LOADAVG_MX@
|
|
@@ -95,43 +99,43 @@ atrun: atrun.in
|
|
$(CC) -c $(CFLAGS) $(DEFS) $*.c
|
|
|
|
install: all
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(etcdir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(bindir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(atdatadir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(docdir)
|
|
- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(atdocdir)
|
|
- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(IROOT)$(ATSPOOL_DIR) $(IROOT)$(ATJOB_DIR)
|
|
- chmod 1770 $(IROOT)$(ATSPOOL_DIR) $(IROOT)$(ATJOB_DIR)
|
|
- touch $(IROOT)$(LFILE)
|
|
- chmod 600 $(IROOT)$(LFILE)
|
|
- chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
|
|
- test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(IROOT)$(etcdir)/
|
|
- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(IROOT)$(bindir)
|
|
- $(LN_S) -f at $(IROOT)$(bindir)/atq
|
|
- $(LN_S) -f at $(IROOT)$(bindir)/atrm
|
|
- $(INSTALL) -g root -o root -m 755 batch $(IROOT)$(bindir)
|
|
- $(INSTALL) -g root -o root -m 755 batch-job $(IROOT)$(atdatadir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man1dir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
|
|
- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
|
|
- $(INSTALL) -g root -o root -m 755 atd $(IROOT)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
|
|
- $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
|
|
- cd $(IROOT)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
|
|
- $(INSTALL) -g root -o root -m 644 atd.8 $(IROOT)$(man8dir)/
|
|
+ $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(etcdir)
|
|
+ $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(bindir)
|
|
+ $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(sbindir)
|
|
+ $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(atdatadir)
|
|
+ $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(docdir)
|
|
+ $(INSTALL) -g root -o root -m 755 -d $(DESTDIR)$(atdocdir)
|
|
+ $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
|
|
+ chmod 1770 $(DESTDIR)$(ATSPOOL_DIR) $(DESTDIR)$(ATJOB_DIR)
|
|
+ touch $(DESTDIR)$(LFILE)
|
|
+ chmod 600 $(DESTDIR)$(LFILE)
|
|
+ chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(DESTDIR)$(LFILE)
|
|
+ test -f $(DESTDIR)$(etcdir)/at.allow || test -f $(DESTDIR)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(DESTDIR)$(etcdir)/
|
|
+ $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(DESTDIR)$(bindir)
|
|
+ $(LN_S) -f at $(DESTDIR)$(bindir)/atq
|
|
+ $(LN_S) -f at $(DESTDIR)$(bindir)/atrm
|
|
+ $(INSTALL) -g root -o root -m 755 batch $(DESTDIR)$(bindir)
|
|
+ $(INSTALL) -g root -o root -m 755 batch-job $(DESTDIR)$(atdatadir)
|
|
+ $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man1dir)
|
|
+ $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man5dir)
|
|
+ $(INSTALL) -d -o root -g root -m 755 $(DESTDIR)$(man8dir)
|
|
+ $(INSTALL) -g root -o root -m 755 atd $(DESTDIR)$(sbindir)
|
|
+ $(INSTALL) -g root -o root -m 755 atrun $(DESTDIR)$(sbindir)
|
|
+ $(INSTALL) -g root -o root -m 644 at.1 $(DESTDIR)$(man1dir)/
|
|
+ cd $(DESTDIR)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
|
|
+ $(INSTALL) -g root -o root -m 644 atd.8 $(DESTDIR)$(man8dir)/
|
|
sed "s,\$${exec_prefix},$(exec_prefix),g" <atrun.8>tmpman
|
|
- $(INSTALL) -g root -o root -m 644 tmpman $(IROOT)$(man8dir)/atrun.8
|
|
+ $(INSTALL) -g root -o root -m 644 tmpman $(DESTDIR)$(man8dir)/atrun.8
|
|
rm -f tmpman
|
|
- $(INSTALL) -g root -o root -m 644 at.allow.5 $(IROOT)$(man5dir)/
|
|
- cd $(IROOT)$(man5dir) && $(LN_S) -f at.allow.5 at.deny.5
|
|
- $(INSTALL) -g root -o root -m 644 $(DOCS) $(IROOT)$(atdocdir)
|
|
- rm -f $(IROOT)$(mandir)/cat1/at.1* $(IROOT)$(mandir)/cat1/batch.1* \
|
|
- $(IROOT)$(mandir)/cat1/atq.1*
|
|
- rm -f $(IROOT)$(mandir)/cat1/atd.8*
|
|
+ $(INSTALL) -g root -o root -m 644 at.allow.5 $(DESTDIR)$(man5dir)/
|
|
+ cd $(DESTDIR)$(man5dir) && $(LN_S) -f at.allow.5 at.deny.5
|
|
+ $(INSTALL) -g root -o root -m 644 $(DOCS) $(DESTDIR)$(atdocdir)
|
|
+ rm -f $(DESTDIR)$(mandir)/cat1/at.1* $(DESTDIR)$(mandir)/cat1/batch.1* \
|
|
+ $(DESTDIR)$(mandir)/cat1/atq.1*
|
|
+ rm -f $(DESTDIR)$(mandir)/cat1/atd.8*
|
|
if test x"$(systemdsystemunitdir)" != xno; then \
|
|
- $(INSTALL) -o root -g root -m 755 -d $(IROOT)$(systemdsystemunitdir); \
|
|
- $(INSTALL) -o root -g root -m 644 atd.service $(IROOT)$(systemdsystemunitdir); \
|
|
+ $(INSTALL) -o root -g root -m 755 -d $(DESTDIR)$(systemdsystemunitdir); \
|
|
+ $(INSTALL) -o root -g root -m 644 atd.service $(DESTDIR)$(systemdsystemunitdir); \
|
|
fi
|
|
|
|
dist: checkin $(DIST) $(LIST) Filelist.asc
|
|
--
|
|
2.25.1
|
|
|