e611813145
Fix build of libcpprestsdk with boost 1.70.0 Fixes: - http://autobuild.buildroot.org/results/65840c7c5b337f1d4e5768d8e68198a5449603fd Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
67 lines
2.6 KiB
Diff
67 lines
2.6 KiB
Diff
From f810ca2e800e9b55be41c5911cf1d1185fcd516b Mon Sep 17 00:00:00 2001
|
|
From: Stefan Floeren <42731906+stefan-floeren@users.noreply.github.com>
|
|
Date: Wed, 17 Apr 2019 10:06:18 +0000
|
|
Subject: [PATCH] Fix missed entries; fix testing
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Retrieved from:
|
|
https://github.com/zaphoyd/websocketpp/pull/814/commits/f810ca2e800e9b55be41c5911cf1d1185fcd516b]
|
|
---
|
|
CMakeLists.txt | 2 +-
|
|
websocketpp/transport/asio/connection.hpp | 3 +--
|
|
websocketpp/transport/asio/endpoint.hpp | 7 ++-----
|
|
3 files changed, 4 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 2786aba9..951de975 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -202,7 +202,7 @@ if (BUILD_TESTS OR BUILD_EXAMPLES)
|
|
endif ()
|
|
|
|
if (NOT Boost_USE_STATIC_LIBS)
|
|
- add_definitions (/DBOOST_TEST_DYN_LINK)
|
|
+ add_definitions (-DBOOST_TEST_DYN_LINK)
|
|
endif ()
|
|
|
|
set (Boost_FIND_REQUIRED TRUE)
|
|
diff --git a/websocketpp/transport/asio/connection.hpp b/websocketpp/transport/asio/connection.hpp
|
|
index 1ccda8f3..57dda74a 100644
|
|
--- a/websocketpp/transport/asio/connection.hpp
|
|
+++ b/websocketpp/transport/asio/connection.hpp
|
|
@@ -462,8 +462,7 @@ class connection : public config::socket_type::socket_con_type {
|
|
m_io_service = io_service;
|
|
|
|
if (config::enable_multithreading) {
|
|
- m_strand = lib::make_shared<lib::asio::io_service::strand>(
|
|
- lib::ref(*io_service));
|
|
+ m_strand.reset(new lib::asio::io_service::strand(*io_service));
|
|
}
|
|
|
|
lib::error_code ec = socket_con_type::init_asio(io_service, m_strand,
|
|
diff --git a/websocketpp/transport/asio/endpoint.hpp b/websocketpp/transport/asio/endpoint.hpp
|
|
index 4b719a97..94509adb 100644
|
|
--- a/websocketpp/transport/asio/endpoint.hpp
|
|
+++ b/websocketpp/transport/asio/endpoint.hpp
|
|
@@ -687,9 +687,7 @@ class endpoint : public config::socket_type {
|
|
* @since 0.3.0
|
|
*/
|
|
void start_perpetual() {
|
|
- m_work = lib::make_shared<lib::asio::io_service::work>(
|
|
- lib::ref(*m_io_service)
|
|
- );
|
|
+ m_work.reset(new lib::asio::io_service::work(*m_io_service));
|
|
}
|
|
|
|
/// Clears the endpoint's perpetual flag, allowing it to exit when empty
|
|
@@ -853,8 +851,7 @@ class endpoint : public config::socket_type {
|
|
|
|
// Create a resolver
|
|
if (!m_resolver) {
|
|
- m_resolver = lib::make_shared<lib::asio::ip::tcp::resolver>(
|
|
- lib::ref(*m_io_service));
|
|
+ m_resolver.reset(new lib::asio::ip::tcp::resolver(*m_io_service));
|
|
}
|
|
|
|
tcon->set_uri(u);
|