5a3f78c919
Until now, libaio contained some architecture specific code to do the syscalls. In fact, it contained a generic variant of the code called syscall-generic.h, but it was showing a warning when it was used, as if it was "not safe". Consequently, in Buildroot, we had chosen to support libaio only on a the subset of architectures that were explicitly handled by libaio. However, between 0.3.110 and 0.3.111, libaio upstream entirely dropped the architecture-specific code: https://pagure.io/libaio/c/97fd3fc0195500e616e34047cba4846164c411d9?branch=master Consequently, in this patch, we: - Bump libaio to 0.3.111. - Switch to the new upstream at https://pagure.io/libaio/. - Drop the 0001-arches.patch patch, which was adding support for MIPS, since we no longer need architecture-specific code. - Update the remaining patches, and Git-format one of them which wasn't Git-formatted. - Drop the BR2_PACKAGE_LIBAIO_ARCH_SUPPORTS option and all its uses. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
33 lines
990 B
Diff
33 lines
990 B
Diff
From 517d9fbe63fbd7e72445dce1cb3f3d8457d838cb Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
Date: Tue, 14 Aug 2018 23:17:25 +0200
|
|
Subject: [PATCH] Makefile: add missing DESTDIR variable use
|
|
|
|
Patch borrowed from OpenEmbedded, available at
|
|
recipes/libaio/libaio-0.3.106/destdir.patch in their source tree.
|
|
|
|
It just adds support for the traditional DESTDIR variable to install
|
|
the library in a different sysroot than the normal /.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
---
|
|
Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index e9dbdb0..c1fb831 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -14,7 +14,7 @@ all:
|
|
@$(MAKE) -C src
|
|
|
|
install:
|
|
- @$(MAKE) -C src install prefix=$(prefix) includedir=$(includedir) libdir=$(libdir)
|
|
+ @$(MAKE) -C src install prefix=$(DESTDIR)$(prefix) includedir=$(DESTDIR)$(includedir) libdir=$(DESTDIR)$(libdir)
|
|
|
|
check:
|
|
@$(MAKE) -C harness check
|
|
--
|
|
2.14.4
|
|
|